Engine lost all power - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-18-2010, 09:11 AM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine lost all power

I need some advice here guys. (1994 7.3idi, non turbo) Was driving about 60mph, engine started surging and lost power, would hardly run 20mph on the floor. Getting air bubbles every time I bleed the injectors or at the schrader valve on the fuel filter. Engine will start and idle but will hardly move my truck now. Already changed the fuel filter and lift pump. I'm thinking i might have injector pump problems again. Any ideas would be greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-18-2010, 06:19 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Silverton, OR
Posts: 2,492
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
If your not getting the right amount of fuel at the schraeder, to me that sounds like it has something to do down more towards the tanks. The Fuel selector valves (FSV's) go bad time to time, and could let you stall out and not draw fuel from either tank. Are you sure your tanks are full?
Reply With Quote Quick reply to this message
  #3  
Old 10-19-2010, 04:19 AM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It has about 1/4 in each tank and the selector does switch tanks. If I run a fuel line from the lift pump into a can of fuel that would eliminate everything from there to the rear right? Thanks for the reply
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors