93 E4OD issues - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2010, 06:31 PM
Premium Member
 

Join Date: Oct 2005
Location: Akron, OH
Posts: 607
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via ICQ to overl0rd Send a message via AIM to overl0rd
93 E4OD issues

Hey all, I have a 93 250 4x4 7.3 non turbo, and I'm having tranny problems. The OD cancel light does not come on at all even with OD cancelled. I started out today with all 4 gears but now starting out in drive i have to put it in 2 to get it to shift to second and if i put it back in drive when its ready it neutrals.
It also feels like the converter locks up in reverse like a direct drive, sometimes it does it in drive as well. I know there is a problem in the neutral safety switch/range switch its only started in a very specific spot in neutral since I bought it but all of a sudden today it will also start in park.

Any ideas/suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-06-2010, 07:05 PM
Premium Member
 

Join Date: Oct 2005
Location: Akron, OH
Posts: 607
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via ICQ to overl0rd Send a message via AIM to overl0rd
On an added note there are no blown fuses, and truck has 72K on it
Reply With Quote Quick reply to this message
  #3  
Old 02-07-2010, 03:21 PM
Premium Member
 

Join Date: Oct 2005
Location: Akron, OH
Posts: 607
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via ICQ to overl0rd Send a message via AIM to overl0rd
Fixed it, ended up being the range switch on the side of the tranny. OD cancel light still doesnt come on though. Found an excellent E4OD diagnosis thread on another board at: E4OD Diagnosis Thread [Archive] - FSB Forums
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:46 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors