No crank, no start. Help! - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-2009, 04:10 PM
Member
 

Join Date: Aug 2009
Location: Wisconsin
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No crank, no start. Help!

1994 F250 7.3 IDI non turbo, auto
Getting pretty upset with the truck, one thing after another.
Latest issue....
This morning I go to start my truck, its 25*F, not plugged in, cycle the glow plugs, and i start cranking.
-Its cranking fast
-About to pop off
Then after about 10 seconds of cranking all of sudden its like my batteries vanished.
When i turn the key to crank it all i got was a CLICK. I then tried to jump accross the starter relay/solenoid on the pass. side fender, and all i got was a click.
So i went out and bought a new starter solenoid (the one that goes on the starter) Installed it tonight, still getting just a click when trying to crank with the key. But not getting any click from jumping accross the starter relay on the fender like i was before..

I need some major help guys, the truck is parked on the side of the street, getting plowed in from plow trucks.
Both batteries are brand new from this november.

Last edited by craigt502; 12-22-2009 at 04:15 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-24-2009, 12:28 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Greensboro, North Carolina
Posts: 189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well if you jumped the solenoid and nothing happened then its not the solenoid. My $$ is on the starter.
Reply With Quote Quick reply to this message
  #3  
Old 12-26-2009, 02:48 PM
Member
 

Join Date: Aug 2009
Location: Wisconsin
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was the starter.
With the new starter the engine cranks over like its 70* outside in the mornings when really its 5*.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:42 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors