'93 F350 Blue Smoke - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-22-2009, 10:22 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'93 F350 Blue Smoke

I have a 1993 7.3 non turbo motor in my dump. I just bought the truck, it has only 55k miles on it. It idles and drives fine. However, it tends to blow some blue smoke until it warms up and sometimes for longer. What can i do to fix it??
Buttz33 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-22-2009, 10:32 AM
Premium Member
 
ryandamo's Avatar
 
Join Date: Jun 2009
Location: Connecticut
Posts: 1,205
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
you may need to put in new glowplugs, on these older motors its common to smoke a little at start up, as long as it starts without any problems i wouldn't worry about it. if it has trouble starting in the cold, then you should probably look into replacing them. if you havent already, i would to go oilburners.net and join over there too, its a very active forum for the old idi engines.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2016 F450 6.7L XLT 4x4Dump, bone stock
1994 F250 7.3L XLT 4x4 ZF5 , Centurion, 4" Lift, 6637, Gulf Coast Bypass Filter, Big fuel tanks, dana 60 swap, No longer dually
1997 F350 7.3L XLT 4x4Dump, E4OD, 4 in exhaust, TS 6 position, 3/8 Trans line+external filter
2013 Scag Turf Tiger 61" 1.1L Caterpillar Diesel
1960 John Deere 440 Backhoe 2-53 detroit
ryandamo is offline  
post #3 of 5 Old 01-14-2010, 04:11 PM
Member
 
500hp2500's Avatar
 
Join Date: Jan 2010
Location: aquadale
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
every diesel retards timing on cold starts which causes smoking and loping sound. so it is normal for it to do this

1996 dodge 2500 12v cummins with all tha go fast parts 459 on dunbars dyno fuel only
1992 f250 banks turbo, turned up fuel and big nozzles and dana 60
500hp2500 is offline  
post #4 of 5 Old 01-14-2010, 04:55 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yea thanks.. its been sitting a while n ive been running it alot and now it barely smokes.. It definately needs glow plugs though bc its a ***** to start.. i have the same truck but a '94 and it's alot easier to start..Does anyone know the best glow plugs to get?
Buttz33 is offline  
post #5 of 5 Old 01-14-2010, 06:29 PM
Powerstroke.org Rookie
 
Join Date: Jul 2007
Location: NE Ohio
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bosch seems to work pretty well for me..... I started it w/o a block heater after sitting all night in below freezing temps and she did just fine. I was quite surprised, actually!
x3rdxStrikex is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome