brake and signal lights just stoped working - Ford Powerstroke Diesel Forum

6.9L IDI Diesels Technical discussion of topics related to vehicles powered by the 6.9 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 03-24-2008, 09:05 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
brake and signal lights just stoped working

hi my trusty 87 brake and signal lights just stoped working fuse isnt blown , cant figure out what it is . any ideas... please
i was towing while this happened
surclay is offline  
post #2 of 8 Old 03-24-2008, 09:09 PM
Compression Ignition Addict
 
Peppy's Avatar
 
Join Date: Feb 2008
Location: Winnipeg
Posts: 386
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
hzard switch is either stuck slightly or burnt all your signals and brake lights go through this switch
Peppy is offline  
post #3 of 8 Old 03-24-2008, 09:09 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: America
Posts: 6,782
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check the connections in the rear.
2005F250 is offline  
post #4 of 8 Old 03-30-2008, 09:23 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no juice to the fuse pannel

well i checked the fuse pannel under the stering wheel and no power to the fuses any sugestions???
surclay is offline  
post #5 of 8 Old 03-31-2008, 07:39 AM
Member
 
Join Date: Dec 2007
Location: Cleveland
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
dumb question.....did you turn on the key before you checked the panel?
nohairracing is offline  
post #6 of 8 Old 03-31-2008, 11:38 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
theres never a dumb question, thanks did and found that the main colum wire harness became loose because the hook that holds it wasnt working , i should of put it together because my cruise control was also not working which i failed to mention
case closed thanks guys
surclay is offline  
post #7 of 8 Old 03-31-2008, 11:53 AM
Premium Member
 
Chiller's Avatar
 
Join Date: Nov 2007
Location: Cranford
Posts: 1,154
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same problem so was it the hazard switch? because i put the hazards on they never went on then i looked out the front window and saw my flashers flashing turned them off and now i have the same problem

2005 F350 4x4 CC LB Lariat
Engine: Puking ModIntake, Innovative SCT Tuned, Straight Pipe, Zoodad, DIY CCV.
Exterior: 8inch Rize 4Link, traction bars, Deaver Leafs, Raceline Rims, 37inch Toyos M/Ts, Leer Cap, Bushwacker Pocket Flares, Tints, Lights and little stuff
Interior: Isspro Gauges, Leds bulbs , Livewire, Overhead DVD, Aftermarket alarm/remote start
Chiller is offline  
post #8 of 8 Old 04-01-2008, 06:47 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i think it was the main conection under the stering coulm the switch that you disconect to take out the signals, usaly the have a lock so they dont get disconected and mine was broke...
surclay is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome