Bought a 6.9 - Ford Powerstroke Diesel Forum
6.9L IDI Diesels Technical discussion of topics related to vehicles powered by the 6.9 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-18-2010, 05:40 PM
Premium Member
 

Join Date: Jun 2009
Location: Connecticut
Posts: 1,195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bought a 6.9

Hey guys, i bought another truck tonight, its an 86 f350 dually rack body with 124k on the clock. Its 2wd, 4 speed and a 6.9 idi. Im gonna get some pictures up when i can.

A few questions, The glow plugs keep cycling on and off , whats up with that.

Second, the radiator will not get hot at all and the heater core hoses are, could the radiator be clogged or thermostat broken?

I just bought it tonight and it got dark so im sure ill have more stuff to ask soon
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-18-2010, 06:02 PM
Compression Ignition Addict
 
Join Date: Jun 2010
Location: In a desert!
Posts: 1,252
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by ryandamo View Post
Hey guys, i bought another truck tonight, its an 86 f350 dually rack body with 124k on the clock. Its 2wd, 4 speed and a 6.9 idi. Im gonna get some pictures up when i can.

A few questions, The glow plugs keep cycling on and off , whats up with that.

Second, the radiator will not get hot at all and the heater core hoses are, could the radiator be clogged or thermostat broken?

I just bought it tonight and it got dark so im sure ill have more stuff to ask soon
Ok. Have you touched the radiator to see if it was hot or are you trusting the thermostat. My thermostat was broken and I had to change the temp sending unit. Mine had 2 of them kept trying to find the bigger one but the autopart people kept giving us little ones. Finally got a big one and it didnt fix it. then we looked and saw a small on that looked like what they gave us and that was the problem. So the thermostat runs off of the small one just incase you have to change it.
Reply With Quote Quick reply to this message
  #3  
Old 08-18-2010, 06:25 PM
Premium Member
 

Join Date: Jun 2009
Location: Connecticut
Posts: 1,195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yea i took the cap off and the coolant inside was cold, where is this snesor located, i literally bought the truck less than 2 hours ago and it got dark so i havent really had time to mess with it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors