dead injection pump??? - Ford Powerstroke Diesel Forum
6.9L IDI Diesels Technical discussion of topics related to vehicles powered by the 6.9 Liter In-Direct Injection Navistar engines.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-26-2010, 05:57 AM
Member
 

Join Date: Apr 2009
Location: McHenry
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation dead injection pump???

over the weekend i went to go put diesel in my 6.9 and on the way, i had no throttle control and it started popping like there was air in the lines. i went home to bleed the lines but it seems that no fuel is getting to the injectors.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-10-2010, 03:01 PM
Powerstroke.org Rookie
 

Join Date: May 2010
Location: Upstate SC
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the fuel/water seperator on the drivers side firewall for leaks, common problem apparently. I just bought an 86 and have been battling the same type problem.
Reply With Quote Quick reply to this message
  #3  
Old 05-10-2010, 06:13 PM
Member
 

Join Date: Apr 2009
Location: McHenry
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well I took the injection pump off and turns out fuel was going into it but wasn't coming out so I figured iit is dead. I gotta go pick up the new one this weekend
Reply With Quote Quick reply to this message
  #4  
Old 05-11-2010, 06:44 AM
Powerstroke.org Rookie
 

Join Date: May 2010
Location: Upstate SC
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bummer considering thats the most expensive part to replace.
Reply With Quote Quick reply to this message
  #5  
Old 05-25-2010, 05:46 PM
Member
 

Join Date: Apr 2009
Location: McHenry
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is there anyway to rebuild the pump for cheap or a cheaper way to get a new one? my buddy's scrap yard has an international motor with i believe a db2 injection pump that came out of an old county dump truck, does anyone think that they are compatible with a 6.9??
Reply With Quote Quick reply to this message
  #6  
Old 05-25-2010, 08:08 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Bismarck, ND/Ft Riley, KS
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Personally, I would pay to get a new one and forget about it. If you arent a injector pump guy I would leave it alone. There are a few gurus around that know these engines but they are on other forums........

IDI's are great but they are becoming a lost art. I wished that mine hadnt gotten wrecked!!!!!

Thad
Reply With Quote Quick reply to this message
  #7  
Old 06-01-2010, 10:08 AM
Member
 

Join Date: Apr 2009
Location: McHenry
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well money is tight right now, i had to pay 300 to repair my car to get it running enough for me to drive it everyday and i lost my job last month so it's hard right now. is there a way i can rebuild it myself?
Reply With Quote Quick reply to this message
  #8  
Old 06-01-2010, 10:21 AM
Member
 

Join Date: Apr 2009
Location: McHenry
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i found an injection pump off an old 5.7 diesel for $55. im not sure but i think they are the same. are those injection pumps the stanadyne db2 also?
Reply With Quote Quick reply to this message
  #9  
Old 06-02-2010, 04:30 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: Bismarck, ND/Ft Riley, KS
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I dont know a hill of beans about those 5.7 diesels......except my buddy had one in an oldsmobile.....

Thad
Reply With Quote Quick reply to this message
  #10  
Old 06-02-2010, 10:03 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Silverton, OR
Posts: 2,492
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I dont think that will work. If I remember correctly the 6.2/6.5 IP's rotate the opposite way IH IDI's rotate. I would assume the 5.7 is the same way. Probably couldnt get the thing to flow well either (so....no power).
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors