1983 6.9 IDI Trouble. Please help!!! - Ford Powerstroke Diesel Forum
6.9L IDI Diesels Technical discussion of topics related to vehicles powered by the 6.9 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-16-2010, 02:18 AM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2010
Location: Clinton, Indiana
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1983 6.9 IDI Trouble. Please help!!!

So first of all I am new to diesels. I bought a 1983 F250 6.9 IDI a couple months ago under the impression that all it needed was a injection pump, I decided to give it a try since it was such a good deal on the truck ($400). So I put an injection pump in it and timed it. Then it wouldn't start so I replaced the starter, batteries, battery cables and fuel filter. Now it turns over fine and it turns over fast enough that it should start up. Instead it just turns and turns. I give it a little shot of starting fluid and it chokes like it wants to start but it won't. I bleed the injectors. Still nothing... Any suggestions?? Thanks.
IDI83Ford is offline  
Sponsored Links
post #2 of 2 Old 03-16-2010, 09:02 AM
Compression Ignition Addict
FordGuy100's Avatar
Join Date: Jun 2008
Location: Silverton, OR
Posts: 2,492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Are you getting fuel at the injectors?

Did you take the IP cover off to take the IP off? If so you might have skipped a gear or two on re-assembly of the new IP and threw it off time.

If your not getting fuel at the injectors it could be the lift pump, or could be as simple as the FSS not getting power (which cuts fuel off when has no power, like when you turn your truck off....).

1985 Ford F-250 with a 6.9 IDI/T-19 4speed 4x4
Paint, Eagle Alloys, Kelly Safari TSR's, ATS turbo, gauges

2004 Jetta TDI 5 speed
2004 2wd Excursion Limited 6.0. Testing how loyal I am to Ford
1997 Passat B4V TDI. 1 of 80 imported in 97. 50 MPG and a factory 25 gallon fuel tank!
FordGuy100 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome