overheating - Ford Powerstroke Diesel Forum
6.9L IDI Diesels Technical discussion of topics related to vehicles powered by the 6.9 Liter In-Direct Injection Navistar engines.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-10-2010, 07:51 PM Thread Starter
Powerstroke.org Rookie
dirtboy953b's Avatar
Join Date: Mar 2009
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

I've got a 86' F-350 6.9. I've been having trouble with it overheating I have replaced the radiator,thermostat,and fan clutch,the water pump is a year old,it does fine just driving around town but when I get out on the highway it get's hot if I pull over it cool's down(fast like less than 2 min.)I used to never have this prob,I used to drive down the highway with my plow all the way up and would not even get warm,I used to have trouble keeping the cab warm...any help would be great thanks!

96' F-250 4x4 5sp dana 60 swap 4:10 gears Turbo with out of a 01' PSD with ATS houseing and wicked wheel,Intake,Intake manifolds and intercooler,custom burned single stage chip...you only need one setting..cutom downpipe 4" exhaust to a 5"stack,LUK single mass flywheel and botton clutch
dirtboy953b is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome