2011 6.7 having fuel mileage problems - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-16-2014, 05:08 PM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2011 6.7 having fuel mileage problems

I have a 2011 F250 6.7 that has been completely deleted. It has EGR delete, dpf delete, and def delete. I have an H&S Mini Max on my truck. I was getting any where from 18-25 mpg. In the last 3-4 months it has been getting 12.5 to 14.5. Everything is set up the same on the truck as when i was getting 18-25. I thought maybe the cold weather had something to do with it but last winter i was getting 18 mpg all winter long. I dont think the cold weather had anything to do with making it drop that much. There isnt any codes on the truck. Has anyone else had this problem. If anyone has any ideas i would be interested in hearing them.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-20-2014, 09:53 AM
Compression Ignition Addict
 

Join Date: Jan 2012
Posts: 329
Thanks: 10
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
How old are the filters?
Reply With Quote Quick reply to this message
  #3  
Old 04-20-2014, 03:41 PM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's not the filters that was first thing I changed when I started having the problem. I'm thinking I could have a bad injector or a couple of them
Reply With Quote Quick reply to this message
  #4  
Old 04-20-2014, 06:12 PM
Member
 

Join Date: Sep 2013
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have a 2013 (see sig) and I'm deleted. Before delete I was getting about 13 city. After delete I am getting 14.5 to 15 city. I have it on the HS tow tune with low boost turned all the way down.

Hope it is not a injectors cause I might have some bad one too and I only have 6900 miles on my truck now.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors