Another Turbo - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Like Tree3Likes
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-20-2014, 03:07 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Another Turbo

I have been experiencing the "shudder", the "lugging" ect. I have had it in and out of my local FORD dealer many times on the 2013 F350. At 2k miles put on a new turbo, issue still persists. Just took it in for the same problem. Told me the MAP sensor is bad and caused another turbo failure.

Question, can a MAP sensor sending bad information, cause mechanical damage to the turbo?

This is the third turbo on the truck, 4 "updates" or "flashes", three different flight recorders and this is the answer I have, "new turbo and MAP sensor you should be fine". Seems fishy! Needless to say I am frustrated with a $60k+ truck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-20-2014, 06:36 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 368
Thanks: 0
Thanked 16 Times in 14 Posts
Feedback Score: 0 reviews
Read this TSB and see if it fits your symptoms...
Do you get a Cleaning Exhaust System Message just before the issue happens?
There is a TSB labeled 13-05-17
For some reason, I cannot paste the link anymore but it does exist and includes 2013 model engines.

2012 F250SDw/6.7L Turbo Diesel Engine Issue - Need Help !!!
Reply With Quote Quick reply to this message
The Following User Says Thank You to poormanscat For This Useful Post:
Kyle T (03-21-2014)
  #3  
Old 03-21-2014, 06:46 AM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by poormanscat View Post
Read this TSB and see if it fits your symptoms...
Do you get a Cleaning Exhaust System Message just before the issue happens?
There is a TSB labeled 13-05-17
For some reason, I cannot paste the link anymore but it does exist and includes 2013 model engines.

2012 F250SDw/6.7L Turbo Diesel Engine Issue - Need Help !!!
I cant seem to find a copy of that TSB online, Seems like its is directed to a Ford Service website that is restricted access.

What I found is people discussing exhaust valve replacement, is that correct?
Reply With Quote Quick reply to this message
  #4  
Old 03-21-2014, 12:14 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 368
Thanks: 0
Thanked 16 Times in 14 Posts
Feedback Score: 0 reviews
yes, they have to replace the exhaust valves in the l/s cylinder head.u will get the cleaning exhaust system message shortly before this problem occurs
Reply With Quote Quick reply to this message
The Following User Says Thank You to poormanscat For This Useful Post:
Kyle T (03-21-2014)
  #5  
Old 03-21-2014, 12:21 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does anyone know if the 2014 shares the same turbo as the 2013 model? Im thinking about canning this one and going to something else, just flat tired of dealing with it! Hate to go Cummings or Duramax, but geeeezzzz.....
Reply With Quote Quick reply to this message
  #6  
Old 03-21-2014, 06:56 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 368
Thanks: 0
Thanked 16 Times in 14 Posts
Feedback Score: 0 reviews
2013-2014 turbos are the same.
Reply With Quote Quick reply to this message
  #7  
Old 03-22-2014, 05:57 AM
Powerstroke.org Fanatic
 

Join Date: Mar 2014
Posts: 120
Thanks: 2
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
map signal wouldnt hurt the turbo, that's them just guestimating maybe cutting oil or coolant supply would, but i doubt a damn map signal would.. Hopefully they're smart enough to do a wiggle test on the EBP pigtail and MAP pigtail.... Ive seen the pigtails have bad connections ALOT, and you get a shudder from turbo open/closing real fast, with driving on the highway being the worst. it Dooesnt always throw a dtc either, you have to watch the signal with an o-scope/IDS and wiggle it to tell.
Reply With Quote Quick reply to this message
The Following User Says Thank You to Scumbag For This Useful Post:
Kyle T (03-22-2014)
  #8  
Old 03-22-2014, 06:07 AM
Compression Ignition Addict
 

Join Date: Apr 2009
Location: North Bay, Ontario
Posts: 3,035
Thanks: 61
Thanked 131 Times in 129 Posts
Feedback Score: 0 reviews
Sorry to hear all that Kyle, good luck
Reply With Quote Quick reply to this message
The Following User Says Thank You to Ontario Trucker For This Useful Post:
Kyle T (03-22-2014)
  #9  
Old 03-22-2014, 06:29 AM
Compression Ignition Addict
 

Join Date: Mar 2013
Posts: 546
Thanks: 7
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Kyle T View Post
Does anyone know if the 2014 shares the same turbo as the 2013 model? Im thinking about canning this one and going to something else, just flat tired of dealing with it! Hate to go Cummings or Duramax, but geeeezzzz.....
How many miles are on your truck? I was under the impression that most all the turbo issues were in the 2011's. I have seen VERY few around the forum's on any 13's, unless they were turned and deleted and messed something up from running the psi's too high.
Reply With Quote Quick reply to this message
  #10  
Old 03-22-2014, 10:39 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by fordtrix View Post
How many miles are on your truck? I was under the impression that most all the turbo issues were in the 2011's. I have seen VERY few around the forum's on any 13's, unless they were turned and deleted and messed something up from running the psi's too high.
I have just under 6400 miles on the truck. I had a aftermarket air intake on it when the first turbo went at 2k. It has been totally stock ( except lift and tires ) since.

I too thought most of the problems were with the 2011 and even early 2012. My dealer is telling me they never see these problems. The shop Forman is just doing what he is told from the Ford engineers, but isn't too confident in the fix.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors