Bad Turbo? - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-29-2013, 03:15 PM Thread Starter
Compression Ignition Addict
 
79_bronco's Avatar
 
Join Date: Feb 2013
Location: Omaha Area
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Bad Turbo?

I am throwing code P132B on my truck right now and it is pretty gutless and doesn't seem to be boosting.

The check engine light isn't on and it didn't go into limp mode or anything but is just short on power.

I didn't clear the code and will probably take it to the dealer Monday but was wondering if anyone here has any ideas.

Its bone stock with 4100 miles on it. And the dealer just changed the oil less than 100 miles ago.


2012 F-250 Lariat Crew Cab Short Bed 4x4 FX4
Ranch Hand Front and Rear
30in Rigid E Series Light
Bilstein 5100 Series Shocks
Truck Cover USA American Work Cover with Toolbox
Kenwood DNX570HD Head Unit
79_bronco is offline  
post #2 of 5 Old 06-29-2013, 05:41 PM
Compression Ignition Addict
 
"Stroker 8"'s Avatar
 
Join Date: Aug 2011
Location: Full-Time Camper in Ca.
Posts: 5,720
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 139
Thanked 95 Times in 93 Posts
Feedback Score: 0 reviews

Larry
2015 F-350 CCLB DRW, Lariat Ultimate,
2nd Gen. 6.7L "Scorpion" Turbo Diesel,
440HP/860TQ, Torque Shift 6-speed,
Tuxedo Black W/Charcoal Black Int.,
14,000 LB GVWR,
3:73 Gears W/Limited Slip,
17" Polished Forge Alum. Wheels,
BFG All-Terrain Tires,
Factory 5th Wheel/Gooseneck Prep Pkg.,
Spray In Bed-Liner,
Supplemental Cab Heater,
Camper Pkg.,
Chrome Pkg.,
FX4-Off Road Pkg.,
Upfitter Switches,
Engine Block Heater,
9025 Lbs. on the CAT Scales.

"Mack Daddy Scorpion!"
"Stroker 8" is offline  
post #3 of 5 Old 07-01-2013, 07:48 AM Thread Starter
Compression Ignition Addict
 
79_bronco's Avatar
 
Join Date: Feb 2013
Location: Omaha Area
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Bad Turbo?-imageuploadedbyag-free1372693668.633904.jpg Well it's at the dealer now. We will see what happens.


Sent from AutoGuide.com Free App


2012 F-250 Lariat Crew Cab Short Bed 4x4 FX4
Ranch Hand Front and Rear
30in Rigid E Series Light
Bilstein 5100 Series Shocks
Truck Cover USA American Work Cover with Toolbox
Kenwood DNX570HD Head Unit
79_bronco is offline  
post #4 of 5 Old 07-01-2013, 12:54 PM Thread Starter
Compression Ignition Addict
 
79_bronco's Avatar
 
Join Date: Feb 2013
Location: Omaha Area
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Well got it to the dealer and apparently they said the code wasn't active when they started looking at it. So I'm going to go pick it up and see how it runs now.


Sent from AutoGuide.com Free App


2012 F-250 Lariat Crew Cab Short Bed 4x4 FX4
Ranch Hand Front and Rear
30in Rigid E Series Light
Bilstein 5100 Series Shocks
Truck Cover USA American Work Cover with Toolbox
Kenwood DNX570HD Head Unit
79_bronco is offline  
post #5 of 5 Old 07-01-2013, 09:08 PM Thread Starter
Compression Ignition Addict
 
79_bronco's Avatar
 
Join Date: Feb 2013
Location: Omaha Area
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I got to talk to the dealer and it is working fine now. After talking to a few friends we decided that the waste gate was most likely stuck open somehow. It had a pretty harsh tow truck ride across town and when the hooked it to the computer the code wasn't active anymore and when I got in they had completely cleared it. Not sure what to think but it is running and driving just fine now. I even got on it leaving the parking lot and had no problem getting 20lbs of boost

Anyone else had something similar happen or any other opinions on why I could hear the turbo but never got any boost on the boost gauge?

A few other items to put the story all together....

Friday I took it in for an oil change at the dealer with 4005 miles on the clock. It drove home just fine then Saturday we went trolling around town looking at some used campers. We had stopped at the store after leaving one of the camper places and I turned it off but then remote started it again because I wanted to come back to a nice cool truck (probably like 60 miles after the initial oil change at that point). Got back in and took off down the road and got on the interstate to head home, realized about 5 miles in on the interstate that it was struggling to pass someone, didn't think much of it, then I hit my exit about 10 miles later and really realized it at that point. I was only about 5 miles from home then so I went ahead and drove the rest of the way since the CEL wasn't on. Got home and pulled to code and that's where it sat until Monday morning. Another item is the CEL never actually came on and I didn't go into limp mode or anything either. Just short on power.



2012 F-250 Lariat Crew Cab Short Bed 4x4 FX4
Ranch Hand Front and Rear
30in Rigid E Series Light
Bilstein 5100 Series Shocks
Truck Cover USA American Work Cover with Toolbox
Kenwood DNX570HD Head Unit
79_bronco is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome