no wiper fluid - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-12-2012, 07:23 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 912
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
no wiper fluid

hello when i press the button to wash the windows the wipers move but nothing comes out. yes it is full and the resivour does not have a leak, what else to check?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-12-2012, 07:27 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,085
Thanks: 41
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by wreedPS View Post
hello when i press the button to wash the windows the wipers move but nothing comes out. yes it is full and the resivour does not have a leak, what else to check?
How cold is it where you live? Lines possibly frozen??

Sent from my DROID RAZR using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #3  
Old 11-12-2012, 07:28 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 912
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
Im in Houston, its not frozen
Reply With Quote Quick reply to this message
  #4  
Old 11-12-2012, 07:33 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,085
Thanks: 41
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Lol ya shouldnt be frozen down there! I would take to dealer and have them check it out. Mine some times doesn't work when its really cold. Below 15f

Sent from my DROID RAZR using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #5  
Old 11-12-2012, 10:46 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Posts: 325
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sounds like it could be a pump or relay gone bad.

I have noticed that compared to previous trucks I've owned the pump seems to be on the weak side of things as my fluid comes out as more of a mist then a strong spray.

just food for thought.
Reply With Quote Quick reply to this message
  #6  
Old 11-13-2012, 07:01 AM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you check the tubing from the reservoir to the spray head. Mine came off in the summer had to push it back on.
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2012, 04:21 PM
Compression Ignition Addict
 

Join Date: Jan 2012
Location: Mansfield
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I thought I had a windshield washer pump issue about a month back. I could clearly hear the pump attempting to pump but no product would come out. I didnt think to check to see if I had fluid in there. I mentioned it to my service guy at the dealership and he said hes seen this problem on a few of the 6.4s and 6.7s. I asked them what they do to remedy this, and he mentioned the first thing they do is take compressed air and blow air back through the lines at the spray nozzles on the hood. Apparently, from what he mentioned, trash gets sucked up and plugs the nozzles. If that doesnt work he said they then move to the pump mounted on the reservoir.

My issue as you prolly guessed was my reservoir was empty(I filled it up when I changed my oil and hardly use it). I filled it back up and was back in business.
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2012, 04:51 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 368
Thanks: 0
Thanked 16 Times in 14 Posts
Feedback Score: 0 reviews
The washer tubing and connectors are exposed to excessive underhood heat and fail quite regularly... have had mine replaced twice now.. dealership service department didnt seem surprised and happens to stock all the required parts to repair!
Reply With Quote Quick reply to this message
  #9  
Old 11-15-2012, 11:11 AM
Member
 

Join Date: Dec 2008
Posts: 52
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
On my 11, they replaced the relay at about 15 months after intermittant malfunction. It worked for a week intermmiitantly, then nothing. They then had to replace the entire motor (the motor activates the relay). Has worked fine for 12 months now. PS, to test what is wrong they need to drain the washer fluid by puling the line off the bottom of the tank- so don't just add water not mixture unless in freezing weather.

Quote:
Originally Posted by wreedPS View Post
hello when i press the button to wash the windows the wipers move but nothing comes out. yes it is full and the resivour does not have a leak, what else to check?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors