A couple of problems. - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2012, 03:08 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 381
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A couple of problems.

So for nearly the whole time I have had this truck, I would periodically get this buzzing noise from the engine bay, roughly 1 minute after shut down. It's very loud, and gradually tappers off until it's gone. I took it to one dealer, who said they had a call into Ford, but in the mean time, did not know what it was or how to fix it. They said it was no danger to the truck, and to keep driving it.

Recently, on an unrelated problem, my truck randomly tells me to pull over safely, and all my power is cut. No matter how much the pedal was pressed, I had nothing. When I finally got to a place with a wide enough shoulder I was doing about 20mph when all the sudden the truck gained all power back, and drove normally (except with a check engine light)

Drove straight to the dealer (only a few miles away)

They found that there was some type of throttle sensor code, and have decided to replace the entire throttle body along with the throttle position sensor, and also the pedal position sensor.

I decided while it was there, I'd have them look into the buzzing, which they did. I had figured it was something to do with the turbo/waste gate/ect, and it did in fact end up being the waste gate solenoid (they think).

Parts are on order for everything. Turns out the waste gate solenoid is on back order, so who knows how long that will take.

My seat belt buckles also squeak REALLY bad, when buckled with a passenger. Of course, they can't re-produce the squeaking lol. Anyone else have this happen?

Doing the 15k mile service while it's in also.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-06-2012, 03:29 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 381
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2011 F250 Waste Gate Solenoid Problem - YouTube
Reply With Quote Quick reply to this message
  #3  
Old 04-10-2012, 11:06 AM
First 6.7 PS Destroyer

 

Join Date: Aug 2009
Location: Somerset, Ky
Posts: 1,720
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by JsnMR2 View Post
Mine done that once....
Reply With Quote Quick reply to this message
  #4  
Old 04-10-2012, 08:16 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2011
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I can also hear the same buzz coming from my truck at shut down, but its nowhere near as loud as yours is. I can barely hear it and it really only is noticeable with the hood up. I think it's always done this since new but at least now if it gets as loud as yours is I will know that it's the waste gate solenoid. Thx
Reply With Quote Quick reply to this message
  #5  
Old 04-11-2012, 11:38 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 381
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cc2cuz View Post
I can also hear the same buzz coming from my truck at shut down, but its nowhere near as loud as yours is. I can barely hear it and it really only is noticeable with the hood up. I think it's always done this since new but at least now if it gets as loud as yours is I will know that it's the waste gate solenoid. Thx
The dealer said they have heard this on another truck, but quiet like yours. Might as well have them take a look at it now.
Reply With Quote Quick reply to this message
  #6  
Old 04-13-2012, 05:13 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 381
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got it back. Replaced the wastegate actuator solenoid, egt sensor, and throttle body w/ throttle positioning sensor. No problems and no buzzing now.

15k service done also.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:14 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors