L.E.D. turn signal Issue - Ford Powerstroke Diesel Forum

6.7 Problems Forum 6.7 Problems Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-10-2012, 05:23 PM Thread Starter
Compression Ignition Addict
 
BIGGPIGG4x4's Avatar
 
Join Date: Apr 2008
Location: NW Indiana
Posts: 1,492
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 1 reviews
L.E.D. turn signal Issue

I tried installing my 2 color L.E.D. Turn signals in my 11, but the white l.e.d.s would flash on and off when I first plug them in, then nothing. The orange would flash with turn signals and hazards on. but couldn't get the white to work. Thru the bulbs in my dads 7.3 and the lights work fine. Anyone have any ideas?



2014 Ford F-350 XLT 4x4 6.7L Powerstroke Diesel
MPD Turbo Kit. HTT367FMW Turbo. H&S Dual Fueler Kit. No Limit Fab. EGR delete and CCV mod. Tuning by Craig@MPD

2011 Ford F-350 XLT 4x4 6.7L Powerstroke Diesel *SOLD*

2004 Ford F-350 "BIGG PIGG EDITION" 6.0L Powerstroke Diesel *SOLD*


Youtube: http://www.youtube.com/user/biggpigg4x4/videos
BIGGPIGG4x4 is offline  
post #2 of 4 Old 02-10-2012, 05:43 PM
Compression Ignition Addict
 
GregsSD's Avatar
 
Join Date: Mar 2008
Location: Santa Rosa, CA
Posts: 1,371
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
Feedback Score: 0 reviews
Sounds like the same problen that we had trying to put them in my sons Dodge Ram. They confuse the computer, I think the solution is to add a ballast resistor to each of the parking lamp wires.

2005 F-250 CC/SB 4x4 medium wedgewood blue

5" lift, 5" Donahoe rear springs, 35x13.50 MTZ's, 18x12 Fuel Hostage wheels, 4.30 gears, Banks 4" exhaust, Airraid intake, SCT from Innovative, ARP headstuds, Bulletproof ficm, Scangauge II, Randy Ellis Design lightbar, Street Scene flares, Harpoon mod, Zoodad mod, LED 2010 taillights, Switchback LED front turn signals
GregsSD is offline  
post #3 of 4 Old 02-11-2012, 06:34 AM Thread Starter
Compression Ignition Addict
 
BIGGPIGG4x4's Avatar
 
Join Date: Apr 2008
Location: NW Indiana
Posts: 1,492
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 1 reviews
so, is this what I need?
RECON Part # 26420 - LED Bulb Load Resistor 6 Ohm / 50 Watt For Signal or Brake light with Dual Filament LED bulbs



2014 Ford F-350 XLT 4x4 6.7L Powerstroke Diesel
MPD Turbo Kit. HTT367FMW Turbo. H&S Dual Fueler Kit. No Limit Fab. EGR delete and CCV mod. Tuning by Craig@MPD

2011 Ford F-350 XLT 4x4 6.7L Powerstroke Diesel *SOLD*

2004 Ford F-350 "BIGG PIGG EDITION" 6.0L Powerstroke Diesel *SOLD*


Youtube: http://www.youtube.com/user/biggpigg4x4/videos
BIGGPIGG4x4 is offline  
post #4 of 4 Old 02-12-2012, 10:34 AM
Member
 
Join Date: Feb 2008
Posts: 86
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
or see if a dealer will perform this https://www.fleet.ford.com/truckbbas...ml/Q-158R3.pdf

its what i planned on doing for the switchback LEDs when i get my truck

2006 F350 XL CC LB 4x4- 71k miles Stolen 12/5/11
Replacement
2012 F350 Lariat CC LB FX4
Crashking is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome