Dealer - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-01-2012, 09:52 PM Thread Starter Fanatic
Join Date: Nov 2010
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

Has anyone had issues with the dealer not listening to your problems or just telling you to live with it?
I can't seem to find a dealer in Tulsa that will work with me on problems.
I am going to take it in again pretty soon and I am dreading it, I know they are going to tell me that it is not a problem or that they submitted it to ford and they refused it.

So far these are the issues I have had them work on:
Within one week the passenger kick panel cracked into two pieces
The backup sensors beep constantly with nothing but an empty parking lot behind me
The speedometer is off by 5mph at 70mph
and a remote start issue

All of which they either told me to live with it, ford won't cover it or that is is not a problem.

I would think that since they get paid either way to fix the problems, wouldn't they be willing to work with me on it?

2011 F-350, 5% on sides back and eyebrow-35% on windsheild, B&W hitch, Weather Tech mats, Tailgate Assist, Hornblaster Conductor Special 240, Toyo M/T 35", Incubus Krawler 20x9, 2.5" ready lift stage 3.

cdrracing is offline  
Sponsored Links
post #2 of 2 Old 02-02-2012, 07:32 AM
Premium Member
camdenlake's Avatar
Join Date: Dec 2011
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
The backup sensors beep constantly with nothing but an empty parking lot behind me

I got this one too. Dealer tinkered for 40min playing and checked with ford. Nothing yet. They say i need to come a couple times and ***** so the engineer folks will listen. Trip two coming up soon. I think its the angle or somthing. When the truck is on a sligh up hill its way worse but if i am on a bit of a decline its much better. Thats been my testing to try and help them fix. Its super annoying. It sucks that they give you the run around. Just dont take it from them. Maybe call Ford and see. Not sure if it works the same in the US or not. When I called Ford about a issue back a few trucks the dealer called me in less than a half hour with all sorts of authorizations to change a ton of parts. Then it was fixed.

Will let you know if i get any result on the reverse sensors. Will be interesting to see if anyone else has the issues on here.


1999 F150 4x4 With the not so stock V10

2009 Shelby GT500 - Grabber Orange

2012 F350 6.7 CC SB FX4 - Sold

2015 Explorer Sport - Black on Black
camdenlake is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome