Leaking oil in cab under dash - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-21-2011, 12:12 PM Thread Starter
Powerstroke.org Rookie
 
extreme26's Avatar
 
Join Date: Sep 2009
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Leaking oil in cab under dash

11 f250 and its leaking oil on my floor mat on the driver side?? looks like its coming off of the break peddle??? anyone have this prob?? i have 6000 miles on the truck
extreme26 is offline  
post #2 of 6 Old 04-21-2011, 12:36 PM
Emergency Services
 
TexasAggie09's Avatar
 
Join Date: Jan 2008
Location: College Station, TX
Posts: 558
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This is a 2011? Take her back to the dealer!

Thanks and Gig 'Em!
White 1995 F350 CC LB 4x4 7.3 SRW
Bought 8/27/09 with 183k miles
4 Position Chip, 35" BFG Mud Terrains, Bilstein 5125 Shocks, DIY Intake 6637, No cat/muffler, Carr Side Steps, Ranch Hand Front Bumper, Headache Rack, Rear Bumper

Fightin' Texas Aggie Class of 2009

TexasAggie09 is offline  
post #3 of 6 Old 04-21-2011, 04:50 PM
Powerstroke.org Rookie
 
Geodude's Avatar
 
Join Date: Jul 2010
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I had that, and it was some lube dripping off the brake pedal assembly. Cleaned it up a few weeks ago and it hasn't been a problem since. I think it was just over-lubed.
Geodude is offline  
post #4 of 6 Old 04-21-2011, 06:46 PM Thread Starter
Powerstroke.org Rookie
 
extreme26's Avatar
 
Join Date: Sep 2009
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks. Thats what I was hoping for a easy fix. I really don't like taking it in... Seems like it always comes back out of fuel and still broke the first few times befor the figure it out! Thanks again
extreme26 is offline  
post #5 of 6 Old 05-09-2011, 02:55 PM
Powerstroke.org Fanatic
 
Join Date: Feb 2010
Location: Orlando/Dr Phillips
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I have this problem on my 2010. I am told it is excess grease coming off of the adjustable pedal assembly. It is definitely more grease like than fluid. I have had the problem intermittently for about 1 1/2 years.

2010 F250 6.4 Black Pioneer Nav, Jl, Memphis audio Subs, Memphis Hybrid Amp.
haccpguy is offline  
post #6 of 6 Old 05-10-2011, 07:19 AM
Ren
Member
 
Ren's Avatar
 
Join Date: Jan 2011
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Geodude View Post
I had that, and it was some lube dripping off the brake pedal assembly. Cleaned it up a few weeks ago and it hasn't been a problem since. I think it was just over-lubed.
Yep..I had one or two drips. Took a rag and wiped up some excess and its all good now.



2011 6.7L F350 DRW CrewCab

Our adventures, www.5thwheeladventures.com
Ren is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome