How to troubleshoot HID wiring - Ford Powerstroke Diesel Forum
6.7 Problems Forum 6.7 Problems Forum

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-21-2011, 07:29 PM
Premium Member
 

Join Date: Sep 2006
Location: Larose, LA
Posts: 536
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
How to troubleshoot HID wiring

I just installed a set of the retro-solutions projector retrofits on the truck and for the life of me cant get the passenger side light to come on regularly. Most times it makes a very fast three buzz noise (da-da-da) and that's it. In fact, the noise is coming through the entire truck (seems like I can hear it at the switch, but I can also hear it by the ballast and the light itself), which may have something to do with how I wired it. Does this sound like a ground issue? I have it grounded directly to each battery, which was the quickest ground I could find (not easy under this new hood). If I take the fuse out and plug it back in a few times I can get the light to work. Driver's side goes just fine
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2011, 06:10 AM
Member
 

Join Date: Dec 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
i had a ground issue where 1 light would be out.I cleaned up my grounds and used plenty of dielectric.I grounded to the core support
Reply With Quote Quick reply to this message
  #3  
Old 04-03-2011, 06:17 AM
Compression Ignition Addict

 

Join Date: Apr 2011
Location: Palmetto, Ga
Posts: 3,394
Thanks: 1
Thanked 12 Times in 12 Posts
Feedback Score: 3 reviews
What kinda hids are they when I did mine I used the factory head light wiring and just plugged them in there are they a single beam hid or high and low beam if single where u do have them wired to
Reply With Quote Quick reply to this message
  #4  
Old 04-03-2011, 01:54 PM
Member
 

Join Date: Dec 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I have retro solutions hid bixenon retrofit. mine plug right in to the factory wiring but have a power lead which went to the battery and the grounds which where shorter I put on the left and right radiator support.I drilled the 2 holes ground to bare metal and loaded up with dielectric and used self tapping bolts
Reply With Quote Quick reply to this message
  #5  
Old 04-03-2011, 02:15 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Yorba Linda,CA
Posts: 189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had the same problem find a better ground and you will be good to go...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:34 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors