Interior lights not coming on? - Ford Powerstroke Diesel Forum
6.7 Powerstroke Interior Discussion 6.7 Powerstroke Interior Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2011, 07:00 AM
Powerstroke.org Fanatic
 

Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 149
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Interior lights not coming on?

Got a question for you guys! I put the Recon door sills on my truck about a week ago and when I opened my door a few days later, they weren't working and my interior lights weren't coming on anymore? First thing I thought was a fuse so I checked all of them, but they're all good! Even checked the ones under the hood. If you push the lights, they'll come on, so it's not the bulbs. They just don't come on if you open the door, unlock it, or if you push the dimmer switch up to turn them on. Any input is much appreciated! And also, if I bring it to the dealership to get it warrantied, do you think they would give me any $h1t with the door sills or should I remove them prior? Thanks again!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-06-2011, 07:11 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: Hay River, NT
Posts: 154
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My guess is it's electrical and has nothing to do with the door sills...don't even go there. It was several days between the installation of the sills and the problem arising. Gotta be electrical/switch problem that is unrelated...probably a $1.29 part...
Reply With Quote Quick reply to this message
  #3  
Old 03-06-2011, 08:12 AM
Powerstroke.org Fanatic
 

Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 149
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by Nthorseman View Post
My guess is it's electrical and has nothing to do with the door sills...don't even go there. It was several days between the installation of the sills and the problem arising. Gotta be electrical/switch problem that is unrelated...probably a $1.29 part...
Well that's my guess as well, but I was hoping someone could tell me where to look next ..... Heard the GEM modules are kinda pricey and not sure if that could be the case?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors