CEL with code PO191 - Ford Powerstroke Diesel Forum
6.7 Performance Parts Discussion 6.7 Performance Parts Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-17-2014, 04:26 PM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CEL with code PO191

I have a 2011 F-450 pickup. Truck has 102909 miles on it. I did the full egr delete, 5" downpipe back without muffler and h&s mini max about 1000 miles ago. I was playing with the differnt gauges on the mini maxx and when i use ICP I can kill the truck and crank back up and get code po191 fuel rail pressure sensor circuit range/performance. Well I cleared the code and set gauges back to what I had them on and it didn't come back on. This morning I noticed while idling I had about 100 rpm lope. So I killed the truck and restarted and it turned over and started but was at such a low rpm that the starter stayed engaged until I touch the throttle then it went to normal. Did this twice. I put it back to stock on the h&s and then redownloaded the deleted tune. It cranked fine but gave me this code again. Rushed to the ford house and bought new fuel filters to have somewhere to start and put them on. So far so good till I killed truck then started 10 min later and got code again. I keep it set on performance. And it won't throw code while driving only if I kill it then crank back up. And not every time either. Anybody had this happen?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-24-2014, 08:39 AM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just an update. Drove from west tx to arkansas and back this weekend running 85 and 90 mph with no troubles at all. About 5 min ago running 15 mph truck just died with no codes gave me a crank but no start for about 10 min. Then started and had the same code come up.
Reply With Quote Quick reply to this message
  #3  
Old 06-24-2014, 10:58 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Are you running out of box h&s tunes or custom mcc tunes from another vendor?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 06-24-2014, 11:10 AM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Out of box h&s. I've put around 100 miles on her since this happened this morning. Stop and go traffic, interstate and shutting off and starting agian and has not happened again.
Reply With Quote Quick reply to this message
  #5  
Old 06-24-2014, 03:51 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Have you tried calling or emailing H&S? If no response I would maybe go ahead and purchase a mcc unlock code and a custom tune from another vendor such as SPE, Gearhead etc.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 06-24-2014, 04:51 PM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No I haven't directly. I've posted in their forum exactly what I posted here with no response. I'll give them a call tomorrow. Thanks for the help.
Reply With Quote Quick reply to this message
  #7  
Old 06-25-2014, 11:26 AM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Talked with h&s tech threw email. They said they have 3 6.7 test trucks and none have experienced what I have with trying to moniter rail pressure and getting code. And to take to ford for diagnostics but I was under the impression that they couldn't hook up to the computers on these things with aftermarket toons without frying computer. Could someone explain to me how that works.
Reply With Quote Quick reply to this message
  #8  
Old 06-25-2014, 01:24 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Is your dealer tune/ delete friendly?

If so just take truck to dealer unplug mini maxx, have them hook there computer up and check codes. As long as they don't update or reflash the trucks computer with the h&s tunes installed all should be fine.

If they say they need to update or reflash the trucks computer, 1. plug your h&s back in,
2. return the truck back to stock.
4. Unplug h&s tuner
5. DO NOT START TRUCK"
6. have them update/ reflash truck computer.
DO NOT START TRUCK"
7. Plug h&s back into truck, instal delete tunes.
8. You are good to go and can start truck.

You can return trucks computer and tune back to stock without replacing stock exhaust and components as long as the truck is not started. But do not start truck until the delete tuning is loaded back onto truck computer.


If your dealer might void your warranty for tuning and deletes, put all stock exhaust and components back on, use h&s to put computer back to stock, then take to dealer and have fix.

Sorry if I am confusing you. I can clear up better if needed.



Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #9  
Old 06-25-2014, 02:16 PM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I understand what your saying. And thanks for clearing that up. I feel like it's a problem with my mini maxx and not my truck because if I use the rail pressure as one of my gauges I'll get that code every time I start the truck. But if not it's hit and miss as to when it will do it. I guess the next time it comes up I'll call the ford place and let them look at it. Sure hate that though.
Reply With Quote Quick reply to this message
  #10  
Old 06-25-2014, 02:34 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Yeah I know what you mean about going to the dealer. I'm one of the lucky ones that have a friendly dealer. They do all my services and dont care about mods.

Have you tried taking h&s tuner out of truck and updating it on your computer then uploading back to truck? Do you know which firmware and update #s you are currently running?

In your h&s menu you can look these up.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors