Need help from u smart guys??? - Ford Powerstroke Diesel Forum
6.7 Performance Parts Discussion 6.7 Performance Parts Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2014, 08:22 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 162
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help from u smart guys???

Hey guys I helped my friend delete his 2011 6.7 today.. We took it for a ride and runs very well for awhile.. then he got on it a couple times the turbo like flutters or something.. Almost like over boosting maybe? It only does it when he gets on it hard.. like around 30 mph but something isn't right? could it be bad turbo? truck only has 15k on it. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-02-2014, 09:00 PM
Powerstroke.org Sponsor
 

Join Date: Aug 2007
Posts: 459
Thanks: 26
Thanked 47 Times in 36 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by taz1 View Post
Hey guys I helped my friend delete his 2011 6.7 today.. We took it for a ride and runs very well for awhile.. then he got on it a couple times the turbo like flutters or something.. Almost like over boosting maybe? It only does it when he gets on it hard.. like around 30 mph but something isn't right? could it be bad turbo? truck only has 15k on it. thanks
possible. the fuel and boost may be exploiting what was prolly a very un-noticeable problem before.
Reply With Quote Quick reply to this message
  #3  
Old 06-02-2014, 09:11 PM
PROUD AMERICAN!!!





 

Join Date: Nov 2009
Location: Wheat Ridge, Colorado
Posts: 15,400
Thanks: 105
Thanked 148 Times in 116 Posts
Feedback Score: 6 reviews
Quote:
Originally Posted by bigrpowr View Post
possible. the fuel and boost may be exploiting what was prolly a very un-noticeable problem before.
The title says the OP needs help from a smart guy and I'm not sure you fitt the requirements bud.












Reply With Quote Quick reply to this message
  #4  
Old 06-02-2014, 09:14 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 162
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hmmm so even if it was fine before it still could be a sign of bad turbo??? thanks
Reply With Quote Quick reply to this message
  #5  
Old 06-03-2014, 10:38 AM
Premium Member
 

Join Date: Oct 2013
Location: Trinity, California
Posts: 675
Thanks: 1
Thanked 44 Times in 40 Posts
Feedback Score: 4 reviews
You need to give more details to me is sounds like a trans issue what tune are you using what boost #s are you seeing did you relearn the trans is it more of a feeling or a noise what's your rail pressure at come on man !!
Reply With Quote Quick reply to this message
  #6  
Old 06-03-2014, 11:10 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 162
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's not the trans. Yes did relearn and drove about 400 miles since. It's like it doesn't like all the boost at once.. Think he seen 36 psi. Someone said there a tsb from ford on this issue ???
Reply With Quote Quick reply to this message
  #7  
Old 06-03-2014, 11:15 AM
Premium Member
 

Join Date: Oct 2013
Location: Trinity, California
Posts: 675
Thanks: 1
Thanked 44 Times in 40 Posts
Feedback Score: 4 reviews
Yea that's def a lot of boost what is the wastegate or spring rated too that might be your issue rite there try loading a street or tow fueling tune and see if you have the same issue or just have your tune MCC 'd to max out slightly lower
Reply With Quote Quick reply to this message
  #8  
Old 06-03-2014, 11:55 AM
Powerstroke.org Sponsor
 

Join Date: Aug 2007
Posts: 459
Thanks: 26
Thanked 47 Times in 36 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Carli'd6.7 View Post
Yea that's def a lot of boost what is the wastegate or spring rated too that might be your issue rite there try loading a street or tow fueling tune and see if you have the same issue or just have your tune MCC 'd to max out slightly lower
If anything the fact that turbo saw 36 psi is a good chance it oversped . If you knew how fast these turbos spun you'd prolly think differently about diagnosing this. It's not a wastegate issue .
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors