H&S MiniMaxx and KEM Green Card (sorry long post) - Ford Powerstroke Diesel Forum
6.7 Performance Parts Discussion 6.7 Performance Parts Discussion

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-01-2012, 11:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
H&S MiniMaxx and KEM Green Card (sorry long post)

I was researching a problem I had last night and now I have questions. I have 3800 miles on my truck and it has had the tuner for 1000 miles. I like having the best of both worlds, power and increased mileage so after reading about the green card I had to get one. I loaded the card and programmed it for level 5 not realizing that I would no longer have the on the fly adjustments. Bummer but I can live with that. First off the truck is a stock CCSB F350 4wd. I haven't had a single problem with it until last night on the way home it started acting up. It was a short 30 minute drive, the coolant was up to temperature and everything seemed ok until about 25 minutes in. It stated surging under light throttle, hesitating while shifting, and when I came to a stop it was loping real bad. Light throttle acceleration was rough for a couple of hundred rpm then smoothed out. Back of the throttle and it started loping again. I got home and started looking into it and the only thing I'm finding is the turbo surge at low rpm/high gear problem. (For what it's worth my 350 doesn't do it but the 550 we have does). So on to the couple of questions I have. I saw where people were mentioning their boost levels going to 30+ psi. While stock I only saw 22, and with the H&S tunes it was still 22. The KEM tune brought it up to 26psi but I also noticed the Pyro1 temp dropped quite a bit from before. Has anyone experienced the same problem I saw? Does the boost I'm seeing make sense? Should the Pyro temp have dropped a few hundred with the KEM tune? Am I just nuts and paranoid? OK forget the last question. For now I'm going back to stock then I'll reload the H&S tune, then the KEM making sure it runs OK for a few days in between.
ScooterKrunch is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-01-2012, 07:26 PM
Powerstroke.org Fanatic
 
TommysDiesel's Avatar
 
Join Date: Jul 2010
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
I'm running KEM and i also had the low rpm surge and truck choking. Spoke with KEM and i will meet with one of the guys one day this week. Give KEM a call they also stand up for their products like H&S

Last edited by TommysDiesel; 04-02-2012 at 07:35 PM.
TommysDiesel is offline  
post #3 of 5 Old 04-01-2012, 09:09 PM
Compression Ignition Addict
 
Bryce18's Avatar
 
Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 126
Thanked 20 Times in 15 Posts
Feedback Score: 0 reviews
Not sure about your pyro temps decreasing. But for your turbo question. I only saw a max of 22lbs with stock exhaust. Now I see 33lbs with H&S and deletes.


Sent from my DROID2 GLOBAL



'11 F250, 6.7 PSD, 3.55 gears, FX4 CC,SB,KR,5% tint, Hankooks w/ moto metal 959's, B&W hitch
Mods
S&B CAI
H&S MINI
5" mbrp strait pipe
H&S EGR block offs
VIAIR OBA
U.P.train horns

Bryce

Last edited by Bryce18; 04-02-2012 at 10:33 AM.
Bryce18 is online now  
post #4 of 5 Old 04-01-2012, 09:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm going to call KEM but I may not get time for a while. Tommy let me know what you find maybe it's a similar problem with the two tunes. Exhaust is one of the things I was thinking with the boost. Pyro 2 is normal, but the highest I saw Pyro 1 was about 160 and that was sitting at a red light. While driving it was below 100. I have to convert the video to post it here, but here is a linkhttp://db.tt/WtZeQl6M to it.
ScooterKrunch is offline  
post #5 of 5 Old 04-02-2012, 07:06 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have some new information. I reloaded the H&S tunes and decided to try it out before returning to stock. Everything is working perfectly fine. Temps are back to what I saw before and no more idle issue. I think I'll leave it be until I can get a hold of KEM and see what my problem is.
ScooterKrunch is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome