Check engine light..... - Ford Powerstroke Diesel Forum
6.7 Motor Problems 6.7 Motor Problems

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-18-2013, 09:49 AM
Member
 

Join Date: Aug 2013
Location: Crestview, Florida
Posts: 52
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Check engine light.....

Wife usually drives the truck and when she was coming home from work yesterday the check engine light came on. My first thought was for DEF fluid (don't really know why I thought that) so I filled it up. It was below half but the empty or fill DEF fluid light was not on. Only other thing I have noticed was the remote start doesn't work. Horn just beeps when you try to start it remotely.

I drove it on a 100 mile round trip last night before dropping it off at the dealer. It ran fine with no other issues except what I mentioned above. I haven't heard from the dealer yet. Any ideas what they might find? I only have 3,165 miles on it, oil not changed yet. Drive it normal, all stock and have only towed about 300 miles with it so far.

Thoughts??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-18-2013, 11:41 AM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,475
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
I am not saying that this is what it is, but when my truck did exactly what you are saying the DEF pump went out. Truck still ran great, just wasn't getting DEF in the exhaust.
Reply With Quote Quick reply to this message
  #3  
Old 10-18-2013, 03:52 PM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 318
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
got a new 13 takeoff def tank and pump if it is.
Reply With Quote Quick reply to this message
  #4  
Old 10-18-2013, 04:01 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,475
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 2013F250Tank View Post
got a new 13 takeoff def tank and pump if it is.
I would assume he is under warranty.
Reply With Quote Quick reply to this message
  #5  
Old 10-18-2013, 04:46 PM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 318
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by BIG Laing View Post
I would assume he is under warranty.
I still have new 2013 def tank and pump take-offs.
Reply With Quote Quick reply to this message
  #6  
Old 10-20-2013, 04:57 PM
Member
 

Join Date: Aug 2013
Location: Crestview, Florida
Posts: 52
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Fixed under warranty. They reprogrammed the computer with updated software to fix the problem. Not really sure why or how that has anything to do with it but oh well. As long as it doesn't become a problem. For now all is well. If it happens again I will let ya'll know.

Steve
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors