"Stop Safely Now" Exhaust Sensor's Bad - Ford Powerstroke Diesel Forum
6.7 Motor Problems 6.7 Motor Problems

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2013, 11:41 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
"Stop Safely Now" Exhaust Sensor's Bad

Bought the used truck in February/13. Had two weeks, alarmed told me to "pull over safely", went dead, wouldn't crank, towed truck to dealer. Dealer replaced EGT sensor (40,091 miles on truck). Warranty covered the cost. 9/24/13 ((53,594 miles)and same thing, except now on a 4-lane hwy "BRIDGE" on I-10, same thing "pull over safely", went dead, wouldn't crank, towed truck to dealer (scary). 9/25/13 dealer calls and says 3 0f 4 exhaust sensors showing bad, and hot-line call is in to Corporate Ford because they have never seen this happen before (wow). Dealer called this after-noon 9/26/13 and said truck is ready, said whoever changed my oil (3 months ago / 6,600 miles ago) overfilled with a little too much oil. They said this in-turn caused motor oil to back-up through the PCV valve line and cause the sensors to detect overheating in the exhaust system. Had to pay for the oil change, no sensors replaced. How in the world could this happen after the supposedly oil change (again 3 months, 6,600 miles ago) cause this to happen now, and why didn't it happen right after the oil was changed 3 months ago??? Unbelievable!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2013, 08:14 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just happened again "Stop Safely Now"! Friday morning in the middle of nowhere at the hunting camp broke down. Called for the wrecker, waited one hour, and the truck finally let me crank it (five minutes before the wrecker showed up out of Yazoo City, MS. Drove the truck back to camp (15 miles away) with the check engine light on. I let it sit for two days (had to wait till Sunday for brother with car hauler), then cranked it back up Sunday morning, and the engine light was OFF (restet itself). Drove four hours South to home with no issues. Parked it at the Ford Place this morning, and i'm anxious to see what they tell me today. They changed the oil 2,000 miles ago, so they have to give me another excuse this time. Anyone out there have this same issue?? Please Help!
Reply With Quote Quick reply to this message
  #3  
Old 11-23-2013, 08:59 PM
Member
 

Join Date: Jun 2012
Posts: 88
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It happened to me today I guess I will take it to the dealer tomorrow, hopefully it will make it.(15 miles)

So what do I do next get rid of the truck, delete, or just hope the dealer fixes it correctly and I don't have anymore troubles. The problem is I've read on here that once you get this problem it keeps coming back. I bought a diesel for the reliability aspect and to pull my 5'er out west. Help
Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 11-23-2013, 09:01 PM
Member
 

Join Date: Jun 2012
Posts: 88
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Should I ask them to replace all of the sensors?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 11-26-2013, 06:08 AM
Member
 

Join Date: Jun 2012
Posts: 88
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So of coarse they would not replace all the sensors. But they said the oil was a quart high and the coolant was a quart low and they don't know why. Is there something I should be asking or demanding that they do? I am suppose to go pick it up here in a couple hours. I have lost all confidence in this truck now.
Reply With Quote Quick reply to this message
  #6  
Old 11-26-2013, 06:21 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yep, sorry bro, i had to trade mine in (it's gone!).. They told me the same thing the second time I took (wrecker) mine to them. They said that whomever changed my oil last put way too much oil in it. I told them it was due for an oil change (it had 6,000 miles since the last oil change, and never was showing too high on the dip stick, complete BS). They didn't change any sensors (3 out of 4 coded) that time, and all they did was change my oil (said they resest on their own)! Well, 2,000 miles later it happened again (2 of 4 coded bad), and they replaced them (#2 & #3). I traded it in on a Z-71 the following week. Complete Idiots! Ford needs to man-up and get the recalls going. It's pathetic!
Reply With Quote Quick reply to this message
  #7  
Old 11-26-2013, 06:25 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What's really sad! The Cheverolet place gave me $1,000 more on trade-in for the truck than what the Ford place would give me. Unbelievable!!
Reply With Quote Quick reply to this message
  #8  
Old 11-26-2013, 06:25 AM
Member
 

Join Date: Jun 2012
Posts: 88
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am beyond pissed off right now they just gave me this story about how the truck oil is suppose to read over full when hot and mid stick when cold. Note they are the only one to do oil changes on this truck and I've always taken it in a couple hundred miles before do.
Reply With Quote Quick reply to this message
  #9  
Old 11-26-2013, 06:28 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yep, it's a scam. I loved my truck, but I couldn't deal with my local incompotent Ford dealership.
Reply With Quote Quick reply to this message
  #10  
Old 11-26-2013, 06:30 AM
Member
 

Join Date: Jun 2012
Posts: 88
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have always been a GM guy this is my first ford. I had a 08 2500hd gasser before this and wasn't happy with the interior and sheet metal on the Chevy so when it came time to trade I decided to look at fords and dodges. I wish the new GM hd trucks were out I would probably go trade.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors