6.7 turbo maybe? - Ford Powerstroke Diesel Forum
6.7 Motor Problems 6.7 Motor Problems

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-04-2012, 07:00 AM Thread Starter
Powerstroke.org Fanatic
Join Date: Jan 2009
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.7 turbo maybe?

Yesterday I was pulling around 10,000lbs and truck was running great. I pull up to a red light and get on it to pull away and my truck starts lugging terrible and i have 3psi boost at full throttle. I pulled over at a gas station killed the truck blew out the air cleaner started it up and it ran great for about 5 miles. This time my screen said pull over now. Boost went to zero and my truck died and wouldn't re-start. It is tuned by h&s so I returned to stock and unplugged and was about to call for a tow. I decided to give one last try and it cranked right up. Got on it and it is putting out 25psi and running strong. So, motor or chip? H&S says its the motor or turbo, but I don't know. Anyone else ever heard of this?
youngstroke is offline  
Sponsored Links
post #2 of 2 Old 08-06-2012, 10:14 PM
Powerstroke.org Rookie
Join Date: Jul 2012
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i wouldnt think its the turbo. i would suspect a electrical issue.sorry i cant help any further.
blown2011 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome