Another Turbo Issue - Ford Powerstroke Diesel Forum

6.7 Motor Problems 6.7 Motor Problems

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 05-17-2012, 06:01 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Another Turbo Issue

2011 6.7 H&S chip with dpf delete, and exhaust. At 40,000 miles on it turbo went out, took it back to ford and they replaced it under warranty. 3,000 miles later turbo goes out again. Hauled it back to ford and they said the seals are out of the turbo. Has anyone else had issues like these and what is the cause?
PwrStroke2012 is offline  
post #2 of 17 Old 05-17-2012, 07:11 AM
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Not yet, but I'm hearing the stories about the turbo going out, stock or tuned
Ghagerman is offline  
post #3 of 17 Old 05-17-2012, 08:14 AM
Powerstroke.org Rookie
 
jvr10350's Avatar
 
Join Date: Feb 2012
Location: Tumbler Ridge
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I've had 2 fail with less than 25000kms and no mods.Same thing though,first one failed at 18000 and second at 22000.And no explanation
jvr10350 is offline  
post #4 of 17 Old 05-17-2012, 08:46 AM
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So it seems not if it gos it's when and how many times
Ghagerman is offline  
post #5 of 17 Old 05-17-2012, 09:50 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
We did have this one chipped, with the delete kit, but under further investigation the last turbo that they replaced they did not plug in some kind of sensor that is on the turbo and they broke it off on the last replacement, but regardless i don't know why this one would fail in 3000 miles, and this one will not be covered under warranty.
PwrStroke2012 is offline  
post #6 of 17 Old 05-18-2012, 06:44 AM
Powerstroke.org Fanatic
 
Castaway's Avatar
 
Join Date: Jan 2012
Location: Petal, MS
Posts: 122
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine is in shop now for Turbo replacement. 34k and no mods. Has seemed weak since 6K and had a surge since 29K. Don't know if any of that was related to turbo but hoping so. When it went down, Sudden loss of power and sounded like power steering pump whine. Oddly no smoke like when my CAT turbos have blown.
This brought to light my further concern of absence of Voltmeter and Oil Pressure Gauge. Would have been nice to help diagnose problem.

2011 F450 6.7 Lariat Pro Hauler
Castaway is offline  
post #7 of 17 Old 05-18-2012, 07:23 AM
Powerstroke.org Fanatic
 
Join Date: Nov 2011
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wonder what the DPF looks like after a turbo failure.

2011 F-350 ECSB 4x4 Lariat Sterling Gray Metallic. 51,000 mi

Mods: Silver Star Ultra bulbs
Removed Photo Sticker Violates TOS
mrplowjr73 is offline  
post #8 of 17 Old 05-18-2012, 07:36 AM
Powerstroke.org Fanatic
 
Castaway's Avatar
 
Join Date: Jan 2012
Location: Petal, MS
Posts: 122
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That is Very Good Question, I will address it when picking up my truck. ... Now that I think about it though, while looking at the old turbo yesterday, it didn't have the usual appearance of slobbered oil everywhere. It just had the thrushaft wobbling around in the housing. which now leaves me wondering what all went thru the heads and valves.

2011 F450 6.7 Lariat Pro Hauler
Castaway is offline  
post #9 of 17 Old 05-18-2012, 08:09 AM
Powerstroke.org Rookie
 
jvr10350's Avatar
 
Join Date: Feb 2012
Location: Tumbler Ridge
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine never pushed any oil when they failed but my friends withe the strait pipe did.

2010 F350 lariet,6" 4 link skyjacker lift,H&S black maxx on hot,dpf/cat delete,S&B intake.
2011 F550 XLT,stock with service truck rig up,Vmac underhood air comp,Cobra 5500 5000lb crane.
jvr10350 is offline  
post #10 of 17 Old 05-21-2012, 12:34 PM
Member
 
EdsTowing's Avatar
 
Join Date: Jun 2010
Location: Mount Pocono, PA
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My 11' F550 failed at 30k in January and it failed again at 41k this past Saturday. It's at the dealer now...down another week...

Thanks,
Ed
EdsTowing is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome