TURBO HAS FAILED 19000 MILES - Ford Powerstroke Diesel Forum
6.7 Motor Problems 6.7 Motor Problems

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 74 Old 04-20-2012, 12:58 PM Thread Starter
Member
 
Join Date: Dec 2010
Location: Penrose colorado
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
TURBO HAS FAILED 19000 MILES

Well here goes, 2011 f250, mini max w/dpf delete afe cold air intake. Jumped in the truck wednesday to go to store and made it about a mile and the turbo is done..... came around a corner and gave it throttle and nothing so I look at boost gauge and there is 0 boost, look in mirror and just solid smoke!
Going to return truck to stock and trailer it to dealer with the trusty 7.3
What a bummer, Ill keep you posted.
penrosetractor is offline  
post #2 of 74 Old 04-21-2012, 02:15 AM
Compression Ignition Addict
 
Nissankidd's Avatar
 
Join Date: Feb 2012
Posts: 208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wow I hate to hear that. Keep us posted.

2015 F-250 platinum
Nissankidd is offline  
post #3 of 74 Old 04-21-2012, 02:56 AM
Compression Ignition Addict
 
"Stroker 8"'s Avatar
 
Join Date: Aug 2011
Location: Full-Time Camper in Ca.
Posts: 5,720
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 139
Thanked 95 Times in 93 Posts
Feedback Score: 0 reviews

Larry
2015 F-350 CCLB DRW, Lariat Ultimate,
2nd Gen. 6.7L "Scorpion" Turbo Diesel,
440HP/860TQ, Torque Shift 6-speed,
Tuxedo Black W/Charcoal Black Int.,
14,000 LB GVWR,
3:73 Gears W/Limited Slip,
17" Polished Forge Alum. Wheels,
BFG All-Terrain Tires,
Factory 5th Wheel/Gooseneck Prep Pkg.,
Spray In Bed-Liner,
Supplemental Cab Heater,
Camper Pkg.,
Chrome Pkg.,
FX4-Off Road Pkg.,
Upfitter Switches,
Engine Block Heater,
9025 Lbs. on the CAT Scales.

"Mack Daddy Scorpion!"
"Stroker 8" is offline  
post #4 of 74 Old 04-21-2012, 05:53 AM
Member
 
Join Date: Dec 2009
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Are you sure an intercooler hose didnt blow off?
socal2ks is offline  
post #5 of 74 Old 04-21-2012, 02:18 PM
Compression Ignition Addict
 
Join Date: Oct 2011
Posts: 173
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
why return to stock?

2011 F260 6.7 CC 4x4 LB
gsxr1300 is offline  
post #6 of 74 Old 04-27-2012, 09:37 AM
Member
 
Join Date: Mar 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
jka74 is offline  
post #7 of 74 Old 04-27-2012, 10:25 AM Thread Starter
Member
 
Join Date: Dec 2010
Location: Penrose colorado
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Returning to stock to try and get it warranty covered ( worth a shot)
Got almost already to go just waiting for a kidney stone to pass so I can finish.
The oil seal is out in the Turbo for sure, had a mess when I removed exaust and I have
checked all tubes and hoses and they are fine......... I do wish there was aftermarket options
so if its not warranty then I would go for it!
penrosetractor is offline  
post #8 of 74 Old 04-27-2012, 10:34 AM
Member
 
Join Date: Dec 2011
Location: Calgary, AB, Canada
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by gsxr1300 View Post
why return to stock?
To try and commit warranty fraud...

Waxy
Waxy is offline  
post #9 of 74 Old 04-27-2012, 11:07 AM Thread Starter
Member
 
Join Date: Dec 2010
Location: Penrose colorado
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry

Quote:
Originally Posted by Waxy View Post
To try and commit warranty fraud...

Waxy
Not that I care what you but my dealer knows that the truck has a chip. I had this truck in the dealer with in 30 days of purchase because the Turbo had a terrible lag and was told that it was normal. $70,000 truck buddy I'm sure you would want it covered under warranty if your $2000 Turbo failed at 19,000 miles!
penrosetractor is offline  
post #10 of 74 Old 04-27-2012, 11:58 AM
Let's Run'em


 
TwinTurboStroker's Avatar
 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,816
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 5
Thanked 16 Times in 15 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Tagged

-Julian
Facebook
4th 6.fo
TwinTurboStroker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome