OIL LEAK!!!!!!!!!! - Ford Powerstroke Diesel Forum

6.7 Motor Problems 6.7 Motor Problems

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-14-2011, 06:19 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2007
Location: KY
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
OIL LEAK!!!!!!!!!!

Truck has 5800 miles on it and has now been leaving a oil spot on my garage floor, it looks like it is coming from the driver side head gasket. Any input would be awsome, going to the dealer Tuesday morning.
hardin2005 is offline  
post #2 of 7 Old 07-15-2011, 04:40 AM
Compression Ignition Addict
 
Jesse@MBRP's Avatar
 
Join Date: Jun 2009
Location: Lexington, KY
Posts: 553
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Jesse@MBRP
Pictures might help out. Take it to the dealer ASAP though.

Jesse Rohr - MBRP Performance Exhaust
email - jrohr@mbrp.com
Become an MBRP fan on Facebook
Jesse@MBRP is offline  
post #3 of 7 Old 07-15-2011, 10:46 AM
Compression Ignition Addict
 
Galaxie's Avatar
 
Join Date: Oct 2009
Location: Robinson Twp PA (Pittsburgh)
Posts: 4,539
Thanks: 2
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Galaxie
I bet it is something silly. I would search it out and tell the dealer where it is.

Colin
59-68Galaxies, Fairlanes
54 Ford Skyliner Glass Top
60 Country Sedan Wagon
87/93 5.0s 347
Buy/Sell/Trade/Service 40s50s60s cars!
06 F350 Dark Stone XLT FX4
SCTX3 Custom Tunes
ARP Head Studs
EGR Cooler gone
MBRP Stright Pipe
Edge Insight
20" Harleys 35" AT2
2011 Tailgate
Eaton TrueTrac
2" Leveling
Black Windows/lights
Blue Spring
03 Turbo
Galaxie is offline  
post #4 of 7 Old 07-27-2011, 05:07 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2007
Location: KY
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sorry been busy with work....I got my truck back Monday evening. Its about a 45 minute trip from the dealer to the house, I parked it and let it set overnight. Tuesday morning before work I checked to see if I had oil under the truck and holy s***! Now the leak I had is worse and the oil filter housing is leaking. Needless to say I called Ford csc yesterday and got assigned a case number on my truck. FYI the repair was an o-ring on the oil separator on the driver side valve cover, obviously not my problem.
hardin2005 is offline  
post #5 of 7 Old 07-27-2011, 05:09 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2007
Location: KY
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I will try to post a few quick pics tonight.
hardin2005 is offline  
post #6 of 7 Old 07-27-2011, 09:09 AM
Compression Ignition Addict
 
Join Date: Nov 2009
Posts: 691
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The Good news is they found the Leak

The Bad news is they don't know what to do with it J/K

Let us know how it works out shouldn't be a Big Deal ,Just Sux not having your truck while they work on it
Lead Foot is offline  
post #7 of 7 Old 07-27-2011, 09:20 AM
Let's Run'em


 
TwinTurboStroker's Avatar
 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,820
Thanks: 5
Thanked 16 Times in 15 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by hardin2005 View Post
Sorry been busy with work....I got my truck back Monday evening. Its about a 45 minute trip from the dealer to the house, I parked it and let it set overnight. Tuesday morning before work I checked to see if I had oil under the truck and holy s***! Now the leak I had is worse and the oil filter housing is leaking. Needless to say I called Ford csc yesterday and got assigned a case number on my truck. FYI the repair was an o-ring on the oil separator on the driver side valve cover, obviously not my problem.
Glad to hear they gotcha fixed up........hopefully it was just a fluke

-Julian
Facebook
4th 6.fo
TwinTurboStroker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome