Electrical Issues? Multiple problems suddenly. - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion 6.7 Electronics Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2013, 03:54 AM
Member
 

Join Date: Oct 2009
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical Issues? Multiple problems suddenly.

My 6.7 has been trouble free since purchased new 15,000 miles ago, until now. A handful of issues have come up, all at the exact same time. Here is a list of my issues:
-Both passenger side door speakers not working at all.
-Sync microphone not working. Truck will say the "please say a command" prompt but does not pick up anything I say.
-Compass will not show up on LCD productivity screen. Just displays "--".
-Interior light/dimmer switch not working.

Like I said, all these came up at the exact same time do I assume they're all from a single issue. The truck is still under warranty, but I don't have the time right now to let go of it. Hoped someone here would have some helpful thoughts. Any help is appreciated. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-30-2013, 05:38 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,085
Thanks: 41
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
I would take to the dealer. It seems now a days when there's electrical issues with the newer vehicles and equipment. Its due to a loose ground wire or connection.

For example a few weeks ago I had a new piece of equipment that turned the A/C on and off by itself, radio volume increased and decreased by itself and working lights turned on and off. And a bunch more crazy stuff. After going through everything the problem was a loose ground wire on the cab.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #3  
Old 04-30-2013, 06:02 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,475
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
Leaking windshield, letting water into the fuse box, And rusting the **** out of everything.
Reply With Quote Quick reply to this message
  #4  
Old 04-30-2013, 06:32 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2012
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could be something as a fuse going bad. May want to check if maybe those symptoms link to a certain fuse in your owners manual. Worth a shot.
Reply With Quote Quick reply to this message
  #5  
Old 05-01-2013, 05:48 AM
Member
 

Join Date: Oct 2009
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've looked through the descriptions of what the fuses are for and couldn't find anything that sounded like any of the things I'm having problems with. Maybe in the next week or two I can get a free minute and take it by the dealership. Until then I'll just have to be annoyed with no passenger side speakers haha. Thanks for the input though!
Reply With Quote Quick reply to this message
  #6  
Old 05-01-2013, 06:13 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2012
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm curious on what it could be.
Another thing to possibly try would to "reset" everything incase their was some sort of glitch. I would assume just like any other car would be to disconnect the batteries for a couple mins. then reconnect them.
Reply With Quote Quick reply to this message
  #7  
Old 05-01-2013, 09:04 AM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 324
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
i have a 2013 250 lariat and before 4k miles the rear tweeters went and the GPS module went. GPs never had me on the road i was actually driving on. SYNC system every other day would say "performing system maintenance".
Reply With Quote Quick reply to this message
  #8  
Old 05-03-2013, 07:59 AM
Member
 

Join Date: Mar 2010
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by augustus89 View Post
My 6.7 has been trouble free since purchased new 15,000 miles ago, until now. A handful of issues have come up, all at the exact same time. Here is a list of my issues:
-Both passenger side door speakers not working at all.
-Sync microphone not working. Truck will say the "please say a command" prompt but does not pick up anything I say.
-Compass will not show up on LCD productivity screen. Just displays "--".
-Interior light/dimmer switch not working.

Like I said, all these came up at the exact same time do I assume they're all from a single issue. The truck is still under warranty, but I don't have the time right now to let go of it. Hoped someone here would have some helpful thoughts. Any help is appreciated. Thanks

Just curious, do you by chance have a lockpick installed? I had lots of weird stuff (some of the same sympthoms) and it turned out to be my lockpick. Irf you do, Coastaltech will replace it free, they know they have a bad batch of them out there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors