Exhaust Fluid Sensor - Ford Powerstroke Diesel Forum

6.7 Electronics Discussion 6.7 Electronics Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-23-2012, 08:36 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Angry Exhaust Fluid Sensor

Satruday I took my truck (2011 F-250) in for the 4th time. I keep getting a "Exhaust Fluid Contaminated" light. They have replaced the sensor twice and did a software upgrade the last time. Has anyone else had this problem? Getting ready to contact a Lemon Law lawyer, this is ridiculous.
snwbdrno01 is offline  
post #2 of 5 Old 01-23-2012, 05:31 PM
Member
 
paulm85's Avatar
 
Join Date: Jan 2008
Location: Southern Il
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Had the exact same problem in mine about 4 months ago. It was the NOx sensor in the exhaust system. Have they tried that?

2011 F-350 6.7 CC/SB
paulm85 is offline  
post #3 of 5 Old 01-24-2012, 06:15 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No, I don't think they checked that. I will call them and let them know.
snwbdrno01 is offline  
post #4 of 5 Old 01-24-2012, 04:16 PM
Compression Ignition Addict
 
Join Date: Aug 2009
Posts: 346
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Same thing happened to me and they replaced the nox sensor as well. My dealer said it was not a isolated case and they have replaced quite a few.

2011 F-350 CCSB
powerstroke43 is offline  
post #5 of 5 Old 01-24-2012, 07:30 PM
Compression Ignition Addict
 
tjbrowder's Avatar
 
Join Date: May 2010
Location: Houston
Posts: 314
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Agree with others....my money is on a bad NOx sensor.

2011 F450 CC/LB 4X4

2010 F250 CC/SB FX4 *SOLD*



Legal Disclaimer: Anything I or anyone else says about my vehicle on this website (Powerstroke.org or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my truck, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
tjbrowder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome