Question for those of you who have upgraded your sound system - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion 6.7 Electronics Discussion

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-10-2011, 02:57 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2011
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question for those of you who have upgraded your sound system

I am in the middle of upgrading my sound system and have run into a stumbling block. I was running new speaker wire for the front speakers and discovered that they have switched to a molex type plug for the front doors, which leaves no room for new wires. So I am curious what others have done. I will be running 300 watts to the mids that will be installed in the doors and I am concerned that the factory wiring will not be adequate.

My system will consist of the folllowing:
Factory Nav
JBL MS-8 for factory integration and processing
JL Audio 600/4 bridged running to mids in the front doors
JL Audio 900/5 for front tweeters, rear fill and sub
Hertz MLK165 components for front stage
Hertz 5x7 coax for rear fill
SPL2K box with a SI BM MKIII

Any help and or input is appreciated.

Shawn
sknoch is offline  
post #2 of 6 Old 11-15-2011, 05:54 AM
Compression Ignition Addict
 
Join Date: Dec 2009
Posts: 176
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
on my 2008 i had to come out of the rubber boot(yes i cut a hole in it) and then into the blank plug that was above the connector on the body side. This wasnt the best solution, but i dressed the wire in loom and it worked for 2 years without any issues.

2016 F350 DRW Platinum
1jeep is offline  
post #3 of 6 Old 11-25-2011, 08:01 AM
Powerstroke.org Rookie
 
tgaston's Avatar
 
Join Date: Nov 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by sknoch View Post
I am in the middle of upgrading my sound system and have run into a stumbling block. I was running new speaker wire for the front speakers and discovered that they have switched to a molex type plug for the front doors, which leaves no room for new wires. So I am curious what others have done. I will be running 300 watts to the mids that will be installed in the doors and I am concerned that the factory wiring will not be adequate.

My system will consist of the folllowing:
Factory Nav
JBL MS-8 for factory integration and processing
JL Audio 600/4 bridged running to mids in the front doors
JL Audio 900/5 for front tweeters, rear fill and sub
Hertz MLK165 components for front stage
Hertz 5x7 coax for rear fill
SPL2K box with a SI BM MKIII

Any help and or input is appreciated.

Shawn
Factory wiring is definitely not sufficient.

I drilled a hole in the door jam and used a piece hydrualic hose. Attached is a pic.
Attached Thumbnails
Click image for larger version

Name:	100_2827.jpg
Views:	235
Size:	30.4 KB
ID:	30930  

2012 F250 6.7 -- Ready Lift 2.5 -- Recon -- 20" Mamba -- 35x12.5 Nitto Trails -- JL Audio C5-570's --JL Audio 13TW5-3 -- JL Audio 900/5 -- DynaMat -- JVC -- BOYO -- Retro Solutions -- Top Gun Customz -- And the list continues...... [/B]
tgaston is offline  
post #4 of 6 Old 06-03-2012, 05:11 AM
Compression Ignition Addict
 
Join Date: Oct 2011
Posts: 173
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
sknoch what spl2k box did you get for your BM MKIII?

2011 F260 6.7 CC 4x4 LB
gsxr1300 is offline  
post #5 of 6 Old 06-05-2012, 08:13 AM
Compression Ignition Addict
 
TX_TRU_STUD's Avatar
 
Join Date: Nov 2010
Posts: 814
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 14
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Is this still an issue in the later trucks? 2012, 2013's?
TX_TRU_STUD is offline  
post #6 of 6 Old 06-05-2012, 01:00 PM
Compression Ignition Addict
 
Join Date: Oct 2011
Posts: 173
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by sknoch View Post
I am in the middle of upgrading my sound system and have run into a stumbling block. I was running new speaker wire for the front speakers and discovered that they have switched to a molex type plug for the front doors, which leaves no room for new wires. So I am curious what others have done. I will be running 300 watts to the mids that will be installed in the doors and I am concerned that the factory wiring will not be adequate.

My system will consist of the folllowing:
Factory Nav
JBL MS-8 for factory integration and processing
JL Audio 600/4 bridged running to mids in the front doors
JL Audio 900/5 for front tweeters, rear fill and sub
Hertz MLK165 components for front stage
Hertz 5x7 coax for rear fill
SPL2K box with a SI BM MKIII

Any help and or input is appreciated.

Shawn
serious system!
where did you get the SI BM MKIII?

2011 F260 6.7 CC 4x4 LB
gsxr1300 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome