HD radio problem/question - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion 6.7 Electronics Discussion

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-12-2011, 01:29 PM Thread Starter
Compression Ignition Addict
Join Date: Nov 2008
Posts: 358
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question HD radio problem/question

I have the 11 lariat F250 with HD radio and noticed that recently the HD radio switches from HD back to Stereo a lot driving down the road or in certain areas. Can anyone tell me if this is normal with HD radio or does this mean I have a problem with the radio? I'm on my second unit already because of other issues with the first one and thought maybe the second one was having issues.

Thanks in advance for any input on this problem, might just be operator error

2011 6.7L, CC, SB, Loaded, LineX bed liner, Weather tech mats, CCR bike carrier, Carli 4.5" 2.5 Pintop, Carli high mount stabilizer, Full spring rear, Fuel Throttle rims, 35" Mickey Thompson ATZs, AMP Steps, Dura Flap Mud flaps with custom weights...
HSrider is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome