Steering Wheel Audio Controls Problem - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion 6.7 Electronics Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-14-2010, 05:34 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Steering Wheel Audio Controls Problem

Hey all,

I'm new to this forum. Just purchased my new Sterling Silver 2011 F-250 CC 6.7 XLT 4X4 two weeks ago and love it. Can't say enough good things about this truck.

However, on my way home tonight from work I tried using the seek button on my steering wheel to change songs on a cd and it quit working. Everything still lights up and the volume control works both ways and the seek button to go back works. It is only the forward seek button that is not working for me at all. I was wondering if anyone else has had similar problems to this. Also, I'm wondering how long and what all would be involved to fix it if I take it to the local dealership. I have to tow my Jeep this Friday as soon a I get off work and will be gone all weekend and will be tied up till after new year's day and will need my truck thoughout this entire time. So basically I'm left with Wednesday/Thursday to get it fixed or else wait till January to get this issue taken care of. What would ya'll suggest? I guess I'll find out tomorrow when I call the dealership but figured I would gauge what you all think before I call.

Thanks,
Daniel
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-17-2010, 11:51 AM
Premium Member
 

Join Date: Jan 2010
Location: South Texas
Posts: 1,091
Thanks: 1
Thanked 8 Times in 7 Posts
Feedback Score: 0 reviews
I'd just pop that switch out and take a look at the wiring behind it. Sounds like it came loose.
Reply With Quote Quick reply to this message
  #3  
Old 12-17-2010, 11:57 AM
Air Assault!!
 

Join Date: Feb 2010
Location: Tampa Bay, FL.
Posts: 675
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 2 reviews
Send a message via AIM to MPTonyT
Those new switches all communicate on the same line in that vehicle. Therefor if one stopped working and the rest still do then that means that the wiring is fine. The switch cluster would need to be replaced would be my guess.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors