Noise while braking and turning right - Ford Powerstroke Diesel Forum
6.7 Drivetrain Problems 6.7 Drivetrain Problems

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2013, 06:06 PM
Emergency Services
 

Join Date: Sep 2011
Location: Bergen County, NJ
Posts: 997
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Noise while braking and turning right

I've noticed a grinding type of noise while braking and turning right, not remotely close to full lock and coming from the right side of the vehicle. I'm also feeling a lot of slack in the braking pressure on the pedal (which I shouldn't with 27,000 miles of little to no trailering or hard braking). Had a new power steering pump installed about 10,000 miles ago.
I'm thinking that the grinding noise could be a bad ball joint? Although I don't see how it's linked to the brake issue, unless it's unrelated. The only other think I can think of is maybe a warped rotor.

Any other suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2014, 07:31 PM
Compression Ignition Addict
 

Join Date: Apr 2014
Posts: 154
Thanks: 7
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
I'm having the same issue with mine: 2012 F250 with 25,000mi. Any update on what you found?
Reply With Quote Quick reply to this message
  #3  
Old 04-29-2014, 09:35 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 912
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
Maybe a failing locking hub?
Reply With Quote Quick reply to this message
  #4  
Old 04-29-2014, 10:52 AM
Emergency Services
 

Join Date: Sep 2011
Location: Bergen County, NJ
Posts: 997
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Still get it, never figured out why. The dealer said something about the hubs a while ago but I don't remember what. Haven't had any hub issues other than the vacuum lines. I just turn up my music and pretend its not there. Going to try taking off my front mud flaps to see if it makes a difference
Reply With Quote Quick reply to this message
  #5  
Old 04-29-2014, 05:26 PM
Compression Ignition Addict
 

Join Date: Apr 2014
Posts: 154
Thanks: 7
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
I get the usual dealer response... It's probably nothing. Just noticed it on the drivers side as well. Hoping whatever it is it fails in the next 11,000 mi. My luck it'll go at 37k.... Just out of warranty
Reply With Quote Quick reply to this message
  #6  
Old 04-29-2014, 06:19 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Posts: 376
Thanks: 2
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
I've had the same thing. '13 10k miles. Been doing it since atleast 4k miles

Brett
Reply With Quote Quick reply to this message
  #7  
Old 07-28-2014, 05:34 PM
Compression Ignition Addict
 

Join Date: Jan 2013
Location: corpus christi
Posts: 413
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
i am having the same problem , i am at 123,000 miles . i replaced rotors and pads last week . the right side was making the noises before i replaced both sides . it is driving me wild . i took the rotors and pads back off , to see if there was any rubbing and there is not . im lost and annoyed . have any of yall had any luck ?
Reply With Quote Quick reply to this message
  #8  
Old 07-29-2014, 02:18 PM
Emergency Services
 

Join Date: Sep 2011
Location: Bergen County, NJ
Posts: 997
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Never found out. Still doing it, when the dealership checked they gave me some line about hubs and never mentioned it again.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #9  
Old 07-29-2014, 03:54 PM
Compression Ignition Addict
 

Join Date: Apr 2014
Posts: 154
Thanks: 7
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Nope... Just make left hand turns!!! Haha. Same thing. No clue at dealer. I'm at 31k and been doing it since new.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors