Battery cable - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-18-2014, 07:53 PM Thread Starter
Compression Ignition Addict
Lancer250's Avatar
Join Date: Apr 2012
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Battery cable

Took truck in for oil change and fuel filters. Now idles rough. Took it to dealer and they put a MAF in it. Didn't help. I took it to Orielly's and one battery tested bad. I replaced both. Found cable on driver side is very corroded. Truck still idles rough. Could the cable be causing this? What could have happened when filters were changed that could have caused this. I do trust my tech and rep but I am at a loss. They did say a couple of the injectors are suspect but they can't fully test due to the delete and mini max. Any ideas??

2011 F250 bone stock CCSB, FX4, PMF traction bars with 4" blocks, PMF 3" front blocks and camber shims, bilstein 5100 shocks.

SOLD!! 2008 ccsb 4x4, mini maxx, s&b cai, flow pro 4" exhaust, mbrp 4" down pipe, Rudy's up pipes, sinister egr deleate, head gaskets, agr head studs, leveling kit, air bags, high idle mod
Lancer250 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome