Stalling then wrench light - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2014, 07:53 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stalling then wrench light

Just bought the truck 3 weeks ago. 08 350 with 33k miles. In last week and a half truck has stalled on me 5 times. Twice while coasting and other times 4 or 5 secs after start up. Hit the key and it turns over but won't crank. Give it 30 secs and it fires right up. After it stalls it will crank back in limp mode. Sometimes it last until you kill and restart truck, sometimes if you run it a few miles and put it in park it will clear. I have never got a cel light and basic scanner won't pull any codes.

The truck did regen once in limp mode and I drove it 65mph until it finished. Pull over and restarted the truck and it was back to normal. I went home and changed the fuel filters and truck ran awesome for 5 days but stalled again today.

All the maintaince ever done was done by ford. I know previous owner and truck has also never had a problem.

Will fords scanner pull a code with just the wrench light? Will it pull a code from a previous light? Ever time I'm tempted to run it to dealership it clears up and runs great. I'm hoping it's egr or dpf related. I plan on deleting both in near future.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-10-2014, 09:20 AM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: Nashua, NH, USA
Posts: 8
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Exclamation

When were the fuel filters last changed? Change interval by the book is 20k miles.

You might have a failing Horizontal Fuel Conditioning Module (HFCM). This is a fuel pump assembly located on the drivers side frame rail and approximately under the driver's door. It is mounted on the inside of the frame rail. The first of 2 fuel filters are in the HFCM assembly.

The HFCM does several things:
- It is a fuel pump and keeps the engine primed with fuel from the tank
- Contains the first fuel filter. The second fuel filter is on the engine.
- The HFCM contains a water separator to catch water contamination in the fuel. The water separator is the fuel system's last line of defense against water ingestion.
- The HFCM also has a Water in Fuel sensor to warn you if the water separator is swamped with water and needs to be drained ASAP.

I had this exact same problem with my 08 F350 6.4L. My symptoms were exactly the same and no codes were thrown. I recognized the symptoms and got it taken care of immediately. The HFCM really was failing and my CPO warranty covered the HFCM replacement, minus my $100 deductible. The HFCM is a $600 part from Ford, so I took full advantage of the CPO warranty. It would have been an $800 job without CPO warranty coverage ($600 HFCM + labor = $800).

You should get this taken care of ASAP because the engine is being starved of fuel and fuel is the ONLY source of lubrication for the high pressure common rail system. The high pressure pump in the CR system won't last long without lubrication and can be VERY expensive to fix.

I've had ZERO problems with my truck since getting the HFCM replaced and that was about 5k miles ago. The truck currently has 83k miles on it, 68k miles were on it when I bought it last year.

Good luck and Welcome to PowerStroke.org.

Last edited by n1das; 02-10-2014 at 09:27 AM.
Reply With Quote Quick reply to this message
  #3  
Old 02-10-2014, 09:50 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did your truck run good from time to time? I'll go 350 miles with out any problems. Cranks and runs fine. I have changed the fuel filters since the problem started. Went 4 days with no problem. I was thinking that it was it then it stalled on me again.
Reply With Quote Quick reply to this message
  #4  
Old 02-10-2014, 10:39 AM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: Nashua, NH, USA
Posts: 8
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Exclamation

Quote:
Originally Posted by SLaCowboy View Post
Did your truck run good from time to time? I'll go 350 miles with out any problems. Cranks and runs fine. I have changed the fuel filters since the problem started. Went 4 days with no problem. I was thinking that it was it then it stalled on me again.
Could be a flakey HFCM. That's how mine was failing.

My truck would intermittently run fine or have problems. I didn't wait long to find out after it happened the first time because I knew it was important to address the problem ASAP. It happened on a Thursday night and was very consistently having problems. Then I parked it and didn't drive it on Friday. On Saturday morning I was at the Ford dealer where I bought the truck from (AutoFair Ford in Manchester NH) and drove it in with it in limp mode (wrench symbol). An hour later they called me and said all fixed and it definitely was due to a failing HFCM. I had changed the fuel filters about 2k miles before this all started. The service was quick because luckily they had one of their truck techs there and was available to get right on it. The service was great considering I drove in there without an appointment.
Reply With Quote Quick reply to this message
  #5  
Old 02-11-2014, 04:19 AM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pull your codes, mine did the same. Was actually the Fuel Pump failing, warranty replacement all good now.
Reply With Quote Quick reply to this message
  #6  
Old 02-11-2014, 04:43 AM
Compression Ignition Addict
 

Join Date: Oct 2013
Location: Carrollton
Posts: 530
Thanks: 2
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Do you run any fuel additive, and are you in a cold climate?
Reply With Quote Quick reply to this message
  #7  
Old 02-11-2014, 01:14 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It started in 30 degree weather but has done it in 60 degree weather. Will ford get a code if only the wrench light is on. Its parked in limp mode now the salesman is picking it up in the morning to bring it in. I've hooked a scanner too it multiple times and it won't pick up a code. Im hoping ford will know exactly what it is and it will be covered being I haven't owned the truck a month yet.
Reply With Quote Quick reply to this message
  #8  
Old 02-13-2014, 07:52 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for replies guys. Dealer called, it is the fuel pump. They are covering it since I bought the truck 3 weeks ago. There are so many topics on here with no answer to the issue so I thought I would let yall know.
Reply With Quote Quick reply to this message
  #9  
Old 04-21-2014, 05:24 AM
Powerstroke.org Rookie
 

Join Date: Apr 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
#1, Thanks for posting your end results! #2, I have the same issue, 08 6.4. Went to pick it up @ the shop (Ford garage) on Friday (it was "done") and it wouldn't start for the tech to pull it out of the service bay. Crank it a few times and it will start right up. My thoughts from the beginning was HFCM as I too would get the "wrench" (shaft more often it seems) then when it starts a P0232 code. Run fines, occassionaly seems down on power. They found the controller (fuse panel) in the RH foot well was getting wet from a water leak (5 actually the "water doctor" said) and changed it. I've officially given up on this truck! I just bought a 6.7 ( crazy but over ebay) by pictures and conversation with the original (currently) owner. Picking it up Tuesday and selling this nightmare once it's "fixed". Ford has spent $30k +- in warranty on this truck and I around $6k. Oh, and I had HFCM replaced @ 98k miles (Ford wouldn't pay for it) and the truck has 137k on it now. I religously drain water seperater (HFCM) and do filter changes. I've never had a hard time restarting after filter change but did this last time when I was perueing the problem on my own. I also had "0" psi @ the schrader valve on the fuel line to the cool fuel. The truck has been great but motor reliability absolutely SUCKS!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors