Truck Shut Off Multiple Times - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-07-2014, 07:54 AM Thread Starter
Compression Ignition Addict
 
TwinTurbo6.4's Avatar
 
Join Date: Oct 2013
Location: Carrollton
Posts: 1,038
Thanks: 16
Thanked 24 Times in 24 Posts
Mentioned: 0 Post(s)
Quoted: 56 Post(s)
Feedback Score: 0 reviews
Truck Shut Off Multiple Times

So I was on my way to work this morning and I got about 1/4 of the way there and my truck just shut off. I lost power steering as well as my brakes. I pulled of the road and I tried to crank it back over and it took maybe 15-20 seconds. So I continued down the road and it did it again. It spuddered for 10 seconds, then it just dies and the battery light, Wrench, and now my check engine light is on. I haven't had time to go to autozone to have it scanned. I drove it straight back home and it didn't shut off anymore. It was making a little bit of a grinding noise. It is -10 here and I have it plugged in now maybe thinking that would be the issue. Anyone have any ideas on what it might be? I had the HPFP replaced in October.

'08 F250 With Some Goodies

TwinTurbo6.4 is offline  
post #2 of 4 Old 01-07-2014, 01:15 PM
Compression Ignition Addict
 
04hdfatboy's Avatar
 
Join Date: Oct 2010
Posts: 4,614
Thanks: 16
Thanked 95 Times in 93 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Sound like maybe the diesel gelled.

08 F350 cc/sb 4X4
h&s minimaxx, 5" flo pro, 4" down pipe, no limit cold air intake, dirty diesel EGR delete with intake elbow, 6.0 exhaust manifolds, custom up pipes, ported intake manifold, Apex 71mm LP turbo, Rudy's cold side pipe, diesel site coolant and transmission filter, diesel site intercooler boots, ccv mod, bilstein shocks, gogo dd solenoid, HID lights, Airdog II 165, PMF traction bars, PMF drag link, moshimoto aluminum radiator
04hdfatboy is offline  
post #3 of 4 Old 01-08-2014, 03:53 AM Thread Starter
Compression Ignition Addict
 
TwinTurbo6.4's Avatar
 
Join Date: Oct 2013
Location: Carrollton
Posts: 1,038
Thanks: 16
Thanked 24 Times in 24 Posts
Mentioned: 0 Post(s)
Quoted: 56 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by 04hdfatboy View Post
Sound like maybe the diesel gelled.
I think that's what it was. I went and bought some diesel kleen and let it run for maybe 2 hours. Then I drove it around after that and no issue. The check engine light went out this morning. Thank you sir!

'08 F250 With Some Goodies

TwinTurbo6.4 is offline  
post #4 of 4 Old 01-08-2014, 06:25 AM
Compression Ignition Addict
 
04hdfatboy's Avatar
 
Join Date: Oct 2010
Posts: 4,614
Thanks: 16
Thanked 95 Times in 93 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Glad it was something simple

08 F350 cc/sb 4X4
h&s minimaxx, 5" flo pro, 4" down pipe, no limit cold air intake, dirty diesel EGR delete with intake elbow, 6.0 exhaust manifolds, custom up pipes, ported intake manifold, Apex 71mm LP turbo, Rudy's cold side pipe, diesel site coolant and transmission filter, diesel site intercooler boots, ccv mod, bilstein shocks, gogo dd solenoid, HID lights, Airdog II 165, PMF traction bars, PMF drag link, moshimoto aluminum radiator
04hdfatboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome