Fuel/Water and Wrench icon - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-02-2014, 04:31 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel/Water and Wrench icon

I have a 2010 F-250, 61K on it.

Traveling down I-95 back to NC and my Fuel/Water Light comes on as well as the nice little wrench Icon. Truck goes into limp mode and I manage to get it back home. Two days prior to this my Fuel/Water light comes on and I have it drained.

Took it to the dealer this morning and they are gonna check it out. Is this a fuel/water issue or could it be something different?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2014, 08:12 AM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 204
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Could be a bad sensor.

Or maybe it's dirty. The last time you drained the water separator, was it a smooth stream of water/whatever and then fuel, or was it a trickle or a drip? If it's not draining properly, it's probably clogged up with gunk and needs to be cleaned out.

How often do you drain it?
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2014, 12:38 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Apparently I do not drain it enough. Didn't know it was recommended to drain it once a month. However, I drained it Monday and the lights came on yesterday.
Reply With Quote Quick reply to this message
  #4  
Old 01-03-2014, 05:31 PM
Powerstroke Techie

 

Join Date: Oct 2009
Posts: 1,677
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
You need to have the cheese cleaned out of the bottom of the HFCM, likely the sensor replaced, and a WIF reset done with IDS.
Reply With Quote Quick reply to this message
  #5  
Old 01-05-2014, 04:48 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yep, it threw a P2269 code. Had to have the HFCM cleaned and the WIF sensor replaced. Good times!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors