Weird noice coming from Maybe the Intake? - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2013, 12:46 PM
Compression Ignition Addict
 

Join Date: Oct 2013
Location: Carrollton
Posts: 391
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Weird noice coming from Maybe the Intake?

I have a 08 Supercrew that is making a weird noise when I let off the throttle with 25+ psi. It isn't the blowoff noice or turbo chirp. It almost sounds like its the intake. I checked the filter, no clogs, made sure everything was tight and no leaks. It spools down slower after that noise. Any Ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-05-2013, 03:01 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
That's called turbo bark. It happens when the vanes in your vgt open and the boost pressure exits the manifold back through your intake.
Reply With Quote Quick reply to this message
  #3  
Old 12-05-2013, 05:38 PM
Compression Ignition Addict
 

Join Date: Oct 2013
Location: Carrollton
Posts: 391
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Ah, I gotcha. I wasn't sure if it was something bad or not. I know I've heard of the knocking noise that happens from a bent push rod or valve. I was hoping it wasn't the starting of that. But thanks!
Reply With Quote Quick reply to this message
  #4  
Old 12-05-2013, 06:27 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
No problem bud.
Reply With Quote Quick reply to this message
  #5  
Old 12-06-2013, 05:54 AM
Compression Ignition Addict
 

Join Date: Oct 2013
Location: Carrollton
Posts: 391
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
I think it might be the ebp sensor. I'm gonna take it off and clean it this weekend just to be safe.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors