Security light flash/no start - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-06-2013, 04:38 PM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Security light flash/no start

Truck fired up like normal, went to turn out of the parking lot and the truck died. The security light was flashing and I couldn't get it to do anything. No start. So I pulled the positive cables off the batteries and hooked them back up and it fired right up and hasn't done it since. Ive noticed others have had this issue, just want to see if anyone has found a definite answer for this. now feel like I cant trust the truck if I never know when its going to do this. Is it something with the key? Or the pats module? Any information is appreciated. The truck is Spartan tuned.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-07-2013, 07:57 AM
Member
 

Join Date: Aug 2012
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by HawkeyeStroker View Post
Truck fired up like normal, went to turn out of the parking lot and the truck died. The security light was flashing and I couldn't get it to do anything. No start. So I pulled the positive cables off the batteries and hooked them back up and it fired right up and hasn't done it since. Ive noticed others have had this issue, just want to see if anyone has found a definite answer for this. now feel like I cant trust the truck if I never know when its going to do this. Is it something with the key? Or the pats module? Any information is appreciated. The truck is Spartan tuned.
I had this problem a few months ago. Very frustrating to say the least. In my case there was a wire corroded under the passenger side battery box. If you look over the forums enough you will see many others had the same problem, yet the fix was completely different. My truck would not fire again no matter what, so I had to go to the dealer since I could not find the issue. There are several modules which need to be satisfied to make the truck start, so it could be a module or the wiring to any one of them. I chased the wiring to the transmission control module (TCM) for a day, and also traced many others. I know this is not great news, but if you can find a damaged wire you may solve the problem, you may not. Good luck.
Reply With Quote Quick reply to this message
  #3  
Old 11-19-2013, 02:28 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 15
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had the same thing happen to me. Backing out of my driveway truck just died and the security light was flashing. Pulled cables off of batteries and cleaned them and truck fired up. One month later I stopped at a store come back out and same thing again. I had to have it towed this time. Got it home and changed both batteries all has been good now for 2 years. Batteries were original motorcrafts that were 3 years old.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:11 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors