6.4 Turbo wont spool - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-06-2013, 01:05 AM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2013
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.4 Turbo wont spool

Alright so i have no boost and my turbo wont spool. Its throwing the p132b code which i have discovered to be the vgt sensor. I have checked the "dog bone" linkage on the actuator to the turbo and its stuck. Will not move freely. Im almost positive its on the turbo side but have not had time to remove it to find out for sure. The pickup has 85k miles and i have no warranty on it. So i guess what im wondering is ways to fix this without having to throw a bunch of money at it. Im fairly mechanically inclined. Ive also looked into replacing the twin turbo setup and that does not look like fun at all. From what ive read its the HP turbo that would be jammed? Would i just be able to replace that easily or take it off and clean it? Any help is appreciated, thanks in advance.
victorymode is offline  
Sponsored Links

6.4, powerstroke, turbo, turbo problem, vgt

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome