2008 ford f450 6.4, just installed new turbo inlet pipe. something burning?? - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-10-2013, 12:03 PM Thread Starter
Powerstroke.org Rookie
Gliddd's Avatar
Join Date: Oct 2012
Location: strafford,NH
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 2008 ford f450 6.4, just installed new turbo inlet pipe. something burning??

so I tackled the job of all jobs without a car lift and did this job completely by myself. took me all of three days to perform with lifting the cab about 4-5inches. The old inlet pipe was cracked at the flex and was making a horrible noise that i could almost feel through the firewall as i went through the rpms. I got it back together lastnight and drove to work today and its been in exhaust cleaning mode non stop which i did expect. but after my 15 minute drive home i pulled in the driveway and shut it off and could smell something burning. i noticed some small amount of smoke coming from under the hood, opened the hood and couldnt really pinpoint where it was coming from. I hope to hell its just the new inlet pipe burning off the oils and what not that were on it from it being manufactured.. and i know i used a crap load of pb blast so that could be burning off of different areas. has anyone done an inlet pipe and had these symptoms after??
Gliddd is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome