6.4 keeps dieing! - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-2013, 05:29 PM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry 6.4 keeps dieing!

I have a 09 6.4 with 62k on it. has a spartan tuner and 4in dual exhaust and thats it. ill be driving along and the truck will just die and shut off, watch the fuel rail pressure just keep dropping till it shuts off. it isnt throwing any codes sometimes can turn the key a few times and itll start back up other times i have to reprogram it and itll fire right back up and drive fine. it happens every two weeks r so but one time it did it 6 times in one day and wouldnt restart. i put both fuel filters in it and it ran good untill today. spartan says they doubt its the programer so i dont kno what else it could be. lift pump? itll run great for a week r two then it happens again i cant even go on a long drive or a trip somewhere bcuz im scared it will die and not restart. i love the truck but really dissapointed in it shoulda kept my 7.3 any help is greatfully appriciated thanks!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-04-2013, 06:23 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,209
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
need to run a lift pump pressure test to see if the base fuel pressure stays at least or around 8lbs or so, if so then it may be the high pressure fuel pump,

im reaalyy curious why you are getting any codes ,it really should be leaving something in memory
Reply With Quote Quick reply to this message
  #3  
Old 06-05-2013, 12:58 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: State of Acceleration
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well I am interested also ..my truck does the same thing off and on. I have a H&S and if I reprogram it, it will restart also. I have been trying to figure mine out for about 4 months... mine seems to be cold related meaning when its warm out side say above 60 it happens less than say 40 outside. mine is a 08 dpf deleted and egr deleted. never any codes and all checks out ok on the snap on scanner..I will be watching this.
Reply With Quote Quick reply to this message
  #4  
Old 06-06-2013, 09:02 AM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tried putting an H&S in it last night did the same exact thing when it runs good the rail pressure at idel and WOT are good but when she's not running good I bearly have any I check wires filters everything and found nothing. Doing a pressure test on the lift pump tonight that's what I leaning towards I have an AirDogII on the way just incase ill let you know what I find
Reply With Quote Quick reply to this message
  #5  
Old 06-06-2013, 12:00 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: State of Acceleration
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If it is like my truck you will find that the pressure is ok... I changed my lift pump just to be sure. The thing that always gets me is if its was the lift pump why will it start after you retune it? I talked to H&S and they said if the truck was shutting down due to a code such as a DPF code or ect, when you re tuned it, it would clear the code and start back up but I never had a code come up but kinda seemed possible ??? Keep us posted Oh and I keep my 7.3 so I drive it when the 6.4 is down
Reply With Quote Quick reply to this message
  #6  
Old 06-06-2013, 01:08 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 2,789
Thanks: 0
Thanked 19 Times in 17 Posts
Feedback Score: 0 reviews
If you lose communication with a Mini Maxx while the truck is running, you'll lose your AC compressor and other things, and the truck won't restart until you reprogram it.

Kinda sounds like a wiring issue. Are the big wire bundles on the driver side fender area in good shape, not chafed, etc?
Reply With Quote Quick reply to this message
  #7  
Old 06-06-2013, 05:57 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: State of Acceleration
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That would be true but I don't have a mini Max on it.... I took it off for that reason its running the xrt pro now.
Reply With Quote Quick reply to this message
  #8  
Old 06-06-2013, 07:32 PM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It has only threw codes once for the EGR low rail presssure injectors and some other stuff i cant remember which led me possibly to the HPFP if the wire chafe they will throw these codes but no fuses have blown and i have good rail pressure when it runs good. i will be doing the pressure test tomaro morning. the Air Dog II should be here to tomaro so hopefully thats the problem
Reply With Quote Quick reply to this message
  #9  
Old 06-08-2013, 06:07 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 2,789
Thanks: 0
Thanked 19 Times in 17 Posts
Feedback Score: 0 reviews
My point is that if you get a brief communication interruption, it will cause similar issues, so I would be looking at wiring harness issues
Reply With Quote Quick reply to this message
  #10  
Old 06-11-2013, 08:49 AM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Believe it was the lift pump. Put the air dog in runs great hasnt died no codes running like a champ....for now
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors