08 6.4L No crank no start - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-03-2013, 08:42 AM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
08 6.4L No crank no start

Okay, I have a 2008 6.4L that runs great, but about every 6 months or so it flashes messages across the info center such as check brake system, trailer brake module fault, oil light, security light. There is nothing to the radio. Glow plugs will cycle, can hear the fuel pump running but will not even crank. There is also a humming noise coming from behind the air filter box, that continues until you unhook the batteries or they run dead. Have had it to the dealer many times and they find nothing wrong with it. Any ideas? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-04-2013, 09:06 AM
Dont Mess With Texas!


 

Join Date: Apr 2010
Location: Corpus Christi TX
Posts: 5,664
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Is this just a random incident? How did you get it to the dealer if it wont crank or start?

Or are you saying this happens everyonce in a while to you?

Have you checked for faulty wiring, main battery cables? maybe in the main harness under the dash something is frayed?
Reply With Quote Quick reply to this message
  #3  
Old 06-04-2013, 11:20 AM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is a random incident. But happens about every six months.

It starts with the power to the radio going out and then coming back on, the the check brake system message comes on. If you shut it off, then is when all the dash messages go crazy, then you can hear the humming noise and it will not start again.
This last time, I unhooked the batteries for a full 24 hours and it is just fine again.

It has been towed to the dealer in the past.
Reply With Quote Quick reply to this message
  #4  
Old 06-10-2014, 05:29 AM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Location: Birmigham, AL
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you ever solve the issue, mine does the same. Interestingly it will start with the remote when this happens.
Reply With Quote Quick reply to this message
  #5  
Old 06-10-2014, 06:32 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2013
Posts: 140
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by rooroo View Post
Okay, I have a 2008 6.4L that runs great, but about every 6 months or so it flashes messages across the info center such as check brake system, trailer brake module fault, oil light, security light. There is nothing to the radio. Glow plugs will cycle, can hear the fuel pump running but will not even crank. There is also a humming noise coming from behind the air filter box, that continues until you unhook the batteries or they run dead. Have had it to the dealer many times and they find nothing wrong with it. Any ideas? Thanks
Sounds like your batteries are on the way out....
Reply With Quote Quick reply to this message
  #6  
Old 06-10-2014, 07:20 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am not sure, we haven't trusted it enough to take it any where lately. We replaced the GEM, there was only one dealer that we could find that would do it without wanting to do any diagnostics to the truck. As far as I can tell the problem is fixed but like I said we have not taken it any where(leave town with it). We do not have remote start so I don't know if that would have worked on ours.

The batteries have been replaced about 4 times, so unless it has to have Ford factory batteries, that is not the issue.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors