Transfer Case? - Ford Powerstroke Diesel Forum

6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-29-2013, 12:42 PM Thread Starter
Compression Ignition Addict
 
Skorchrock's Avatar
 
Join Date: Oct 2012
Location: Texas
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Transfer Case?

I have this humming/grinding noise only in 4 wheel........Has anyone ever had this? Bearings? Haven't draind the fluid because it looks like it hasn't been touched "no tooling marker and still has paint over fill hole" even though Ford said they did it at 60K. I'm thinking about trying to get them to replace this if I find out they didn't change the fluid. Just wanting to pass this buy ya'll to see if anyone has had the same issue. BTW 4 wheel stil works, just makes noise.

Skorchrock is offline  
post #2 of 2 Old 05-29-2013, 12:57 PM Thread Starter
Compression Ignition Addict
 
Skorchrock's Avatar
 
Join Date: Oct 2012
Location: Texas
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Now they're telling me thee fluid isn't do til 150K.....Said it could be the actuator?

Skorchrock is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome