Annoying sounds - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2008, 09:45 PM
Project Abused

 

Join Date: Nov 2007
Location: Hampton, VA
Posts: 1,165
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Annoying sounds

Don't know what it is but man it just got really worse tonight. I started with an annoying squeek coming from under the bed like when I would hit a bump in the road even little ones it would squeek all the time. Now when I step on it easly and let off the pedal I hear another noise like... I dunno but even when I turn I hear it even more so, it slows down when I let off the pedal. I am hoping it nothing real serious and can be a cheap fix but with all the mods on it im gonna bet the dealership is gonna take my warranty
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-24-2008, 10:35 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,720
Thanks: 4
Thanked 15 Times in 14 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Its your carrier bearing....you shouldn't have a problem with your warranty
Reply With Quote Quick reply to this message
  #3  
Old 11-30-2009, 06:15 PM
Member
 

Join Date: Mar 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same problem, mine was from having to lower the exhaust when I installed my gooseneck hitch. The weld on one of the studs broke and the bracket would move up and down on the stud causing the squeak. Dont know if you have this on yours but hope it helps.
Reply With Quote Quick reply to this message
  #4  
Old 12-01-2009, 05:56 AM
Powerstroke.org Sponsor

 

Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If you go to the dealership they will void your warranty. If it is the carrier bearing, they will say the extra power from the mods caused it. Deff check out the noise, you don't want your driveshaft laying in the road somewhere.
Reply With Quote Quick reply to this message
  #5  
Old 12-04-2009, 01:57 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 529
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I believe I have this same problem, how do I fix it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors