08 f350 lack of power intermittently - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-11-2008, 08:54 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
08 f350 lack of power intermittently

I got a 6.4 L that at times the turbo just shuts down. Be riding around 65 and the boost gauge goes down to zero and trucks slows down.. Anyone else having similar problem? the only codes in the computer were thermostat stuck open p0128 and a over speed condition.
Quazzar is offline  
post #2 of 6 Old 02-11-2008, 08:58 AM
Compression Ignition Addict
 
Barchetta's Avatar
 
Join Date: Sep 2007
Location: Longwood, FL
Posts: 3,323
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Barchetta
Possible it could be in regen.

My boost gauage goes down to 0 when I am on the interstate and it hits regen.

Mark


2008 F-250 Lariat CC 4x4 AKA: Jolene
Dual Alternators (from the factory)
5% Tint All Around
High Idle Mod
Line-X
Roll-N-Lock
Clifford 50.5x

Barchetta is offline  
post #3 of 6 Old 02-11-2008, 09:01 AM
Let's Run'em


 
TwinTurboStroker's Avatar
 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,820
Thanks: 5
Thanked 16 Times in 15 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by Quazzar View Post
I got a 6.4 L that at times the turbo just shuts down. Be riding around 65 and the boost gauge goes down to zero and trucks slows down.. Anyone else having similar problem? the only codes in the computer were thermostat stuck open p0128 and a over speed condition.
.......what do you mean by "over speed condition"? Sounds like regen to me too, but are you haulin azz everywhere?

-Julian
Facebook
4th 6.fo
TwinTurboStroker is offline  
post #4 of 6 Old 02-12-2008, 04:20 PM
Compression Ignition Addict
 
powerstrokes only's Avatar
 
Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by TwinTurboStroker View Post
.......what do you mean by "over speed condition"? Sounds like regen to me too, but are you haulin azz everywhere?
Mine has set this code too, I asked about it and they said everytime you go over 85 (I think) it sets a code, no big deal they said.

Fletcher
'90 F250 Supercab IDI 7.3
Banks Sidewinder Turbo
4'' straight pipe
116,000 miles

'94 F250 single cab IDI Factory Turbo 7.3
3'' banks down pipe
Banks pyrometer
3 1/2'' straight pipe
K&N Air filter
Hypermax air intake
Hydrogen Generator
Pump turned up
Timing advanced
315,000 miles!



'89 F250 4x4 supercab 7.3 IDI
4'' exhaust
pump turned way up!!!
297,000 miles
powerstrokes only is offline  
post #5 of 6 Old 02-16-2008, 12:02 PM
Powerstroke.org Rookie
 
Join Date: Feb 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same problem while i was towing a large 5th wheel with my 2008 f-450. Did not go over 70 , This has happened 3 times . The last time they said it was exhaust sensor. I am worried about towing with it again. I travel alot so I need to fix this problem.any ideas out there?
rakshak is offline  
post #6 of 6 Old 02-19-2008, 05:11 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: Birmingham area Alabama
Posts: 341
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My truck has been doing this on and off since new-- it is at Ford now since last WED. today they have found that a MAP sensor is not reading right- its using a MAP sensor to read boost pressure as well as a boost sensor -if they do not read the same psi it will shut the fuel off because it is confused-- or thats the BS my service guy give me tonight anyways, they are going to order a sensor and have it in tommorrow and TRY to see if that fixes the problem -- I asked them why he just did not pull a new truck off the lot and try the one off of it -- and he just started stuttering --- um u m a h -- we can't do that -it aint right-- anyways I will keep u all posted on the outcome-

Richard N Dawn C

Owner - Campbell Car Carriers
richardndawnc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome