coolant temp - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-03-2013, 06:31 PM Thread Starter Rookie
Join Date: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
coolant temp

okay so I just bought an 08 f250 with 100k its got DPF delete, H&S tuner, and an air intake. The check engine came on about two weeks after I got it and showed a coolant temp sensor code. So I replaced the Thermostat and put more coolant in it but that didnt help. My coolant temp is far exceeding my trans temp by 50 or 60 degrees farenheit. Does anyone have any idea about what this could be? A leak or blockage somewhere? I sure would appreciate it!
Fordstroker33 is offline  
Sponsored Links
post #2 of 2 Old 04-03-2013, 08:37 PM
Compression Ignition Addict
Join Date: May 2010
Posts: 322
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 3 reviews
Probably your coolant temp sensor.
04blackcrewcab is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome