Adding Coolant... - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-28-2013, 07:17 PM
Member
 

Join Date: Oct 2010
Location: Spruce Grove, Alberta, Canada
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Adding Coolant...

So, I've added coolant 2x in the last month. Twice I've noticed after the truck is at running temp the reservoir is empty. I'm no mechanic so I don't know if anything is wrong. I've had no problems at all so far with my truck, no codes, no abnormal noises, doesn't run rough, temp gauge always reads normal.
Do I have a reason to worry?

Any help or advice would be greatly appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-01-2013, 02:52 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had to do the same, suspect the EGR cooler. Just got the delete kit in from FloPro today. Not wanting to take any chances with failure.
Reply With Quote Quick reply to this message
  #3  
Old 03-01-2013, 03:10 PM
Member
 

Join Date: Oct 2010
Location: Spruce Grove, Alberta, Canada
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am running a Mini Max, I was under the impression they 'shut off' the EGR?? Does this sound right?
Reply With Quote Quick reply to this message
  #4  
Old 03-01-2013, 08:15 PM
Member
 

Join Date: Oct 2010
Location: Spruce Grove, Alberta, Canada
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Adding Coolant...

So I had the truck in for a warranty issue today. They did an oil change, and in the notes it says they found a coolant leak that requires more diagnosis. Would've been nice for the service manager to mention something about that rather than me just happen to figure it out!
That would explain my loss of coolant issue tho.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #5  
Old 03-01-2013, 09:15 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,592
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Even tho h&s shuts it off it can still leak coolant. If your not seeing any on the ground or white residue marks on the degas bottle it's most likely your egr. H&s just stops the valve from opening. Coolant is still running thru the coolers
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors