No heat, green wrench.... !!!!!! - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-28-2013, 06:27 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No heat, green wrench.... !!!!!!

Here we go...

I have a 2008 f-250, around 150,000 miles, I have had thermostats changed, water pump changed, belts changed, service done, and oil temp sensor changed, and the blend motor.

The problem still goes on...

While driving the truck for the first 20 - 30 min everything is ok. But... After that, the engine temp spikes, I get then"reduced engine power" light, and the green wrench light comes on. And the heat blows cold... Then warm for a few seconds.. Then back to cold.

Please help guys... I think the mechanic has gave up
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-28-2013, 08:22 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 198
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I'm not a master mechanic by any means, but could the ECT (Engine Coolant Temperature) sensor have anything to do with this? I see you don't mention having that replaced yet.

What codes is it throwing at the time?
Reply With Quote Quick reply to this message
  #3  
Old 02-28-2013, 09:38 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm sorry I did not mention that, but it was also replaced.

The truck is not throwing any codes...???

It also seams like the "cleaning exhaust filter" comes on a lot. And when it starts to clean it, it goes insane (see above)

Last edited by Baker58; 02-28-2013 at 10:58 PM.
Reply With Quote Quick reply to this message
  #4  
Old 03-01-2013, 06:47 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,006
Thanks: 13
Thanked 37 Times in 36 Posts
Feedback Score: 0 reviews
I have heard head gaskets can cause issues with the heat. Are you puking coolant?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:26 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors